BTT Pad 7 KlipperScreen git repo error

My Pad 7 came with CB1 and a preinstalled suite with Klipper, Mainsail, Moonraker etc. It looks like the initial install is fairly barebones, but with update manager set up so services can install once the pad is online. All components have installed and updated correctly except for KlipperScreen which seems unable to download and gives this error message:

Repo has not been verified, clone aborted

I checked the update manager setup in moonraker.conf but I can’t find any obvious problems:

[update_manager KlipperScreen]
type: git_repo
path: ~/KlipperScreen
env: ~/.KlipperScreen-env/bin/python
requirements: scripts/KlipperScreen-requirements.txt
install_script: scripts/
managed_services: KlipperScreen

I have tried changing the origin to the official repo at but I’m still getting the same error message.
When I run the Hard Recovery option from the Update Manager the web UI gives the aforementioned git clone error, while the screen on the pad flashes with status messages, all of which are OK except one:

Failed to start Access point and authentication server for Wi-Fi and Ethernet. See ‘systemct1 status hostapd.service’ for details.

Does anyone have ideas for what’s going on?
I’m completely new to everything Klipper so I don’t fully understand what the different components do and how everything goes together but I feel the need to point out that there’s been a Klipper interface on the pad since first boot, with full touch support. KlipperScreen.log also updates when I try the Hard Recovery and the messages look okay (keep in mind there’s no printer connected yet).
I have attached KlipperScreen.log in case there’s anything of use there. Note that I received the Pad 7 a few days ago so all the log items from March must have been on the Pad from factory.
Any and all help is greatly appreciated!
KlipperScreen.log (183.0 KB)

Hard to say without such a thing in front of me. Try

  • Login via SSH to the pad
  • Navigate to the KlipperScreen folder, likely /home/biqu/KlipperScreen
  • Execute git pull

Likely you will receive some error messages. Copy and paste the output here, formatted as code with the </> symbol

Thank you!
Git wouldn’t pull because git config and weren’t set:

*** Please tell me who you are.


  git config --global ""
  git config --global "Your Name"

Git pull worked fine after running those commands!
I guess as long as I’m not making any changes of my own I should just use git reset --hard origin/master and I don’t think I need to set up a user for that. I used git a lot at my old job but this is my first time using it in years and I’m definitely rusty.

Anyway, KlipperScreen still shows as invalid in the update manager in the web ui, after running the git reset and rebooting the pad.
Attempting Hard Recovery still throws the same “repo not verified” error message.
Could it be missing git credentials or something? I guess not, since pull, fetch and reset all work through ssh now.
I’d still like to get to the bottom of why the update manager isn’t working, but at least now the local KlipperScreen install is up to date and I have the workaround to keep it that way.

What is the output of:

git remote -v and git status? Does git-fsck --full bring up anything meaningful?

Thanks for your quick reply, here’s the output:

biqu@BTT-Pad7:~/KlipperScreen$ git remote -v
origin (fetch)
origin (push)

biqu@BTT-Pad7:~/KlipperScreen$ git status
On branch master
Your branch is up to date with 'origin/master'.

nothing to commit, working tree clean

The last one failed:

biqu@BTT-Pad7:~/KlipperScreen$ git-fsck --full
git-fsck: command not found
biqu@BTT-Pad7:~/KlipperScreen$ git -fsck --full
unknown option: -fsck
usage: git [--version] [--help] [-C <path>] [-c <name>=<value>]
           [--exec-path[=<path>]] [--html-path] [--man-path] [--info-path]
           [-p | --paginate | -P | --no-pager] [--no-replace-objects] [--bare]
           [--git-dir=<path>] [--work-tree=<path>] [--namespace=<name>]
           <command> [<args>]

I’m starting to suspect the issue is with the Update Manager’s interface with git or something, but that’s odd since sonar and a bunch of other components also update through git and they all updated just fine.

When logging in through SSH the CB1 (Bigtreetech’s low cost RPi CM4 alternative) gives this output:

Welcome to BTT-CB1 2.3.2 Bullseye with Linux 5.16.17-sun50iw9

System load:   96%              Up time:       1 min
Memory usage:  21% of 986M      IP:  
CPU temp:      51°C             Usage of /:    14% of 29G

[ 0 security updates available, 65 updates total: apt upgrade ]
Last check: 2023-05-15 14:18

Last login: Mon May 15 14:25:29 2023 from

I haven’t used Linux in years either, and even then I didn’t really know what I was doing, but it looks as though it wants me to run apt upgrade.
I’ve attached the output of apt list --upgradable as a file to avoid clutter but it all just looks like various Linux components that I don’t think would affect Klipper much:
apt_list_–upgradable.txt (5.7 KB)

Did you do
apt update?

Good luck, hcet14

Sorry, shouldn’t trust the top of my head: git fsck --full

Well, the box is running a native Linux so it makes sense to keep it updated. I do not think that it is related to the initial issue though.

1 Like
biqu@BTT-Pad7:~/KlipperScreen$ git fsck --full
Checking object directories: 100% (256/256), done.
Checking objects: 100% (9368/9368), done.

Doesn’t appear to be a git issue …

Ok, since I’m not a git guru we have now reached the end of my knowledge. What about a brute force approach?

cd ~
rm -rf KlipperScreen
git clone

I’ve seen reviews where they had the same problem and the pad worked just fine so I think I’ll leave it as is for now (it is working fine after all) and see if maybe BTT comes with an update that fixes it at some point.
I feel there’s a chance it would work fine if I ran your suggested code but used the official repo instead of the BTT custom version (though that would break some features on the pad, hence the custom version).
Thank you for your efforts though!

This is boring! Where is your sense for adventure and danger? Where is your spirit to explore the unknown? Where your crusade for hidden knowledge? :innocent:

1 Like

It’s all currently being spent upgrading my Ender 5 Plus (previously upgraded with Exoslides and a Bondtech DDX w/ Mosquito) to a BMG-X2-M dual extrusion setup run by the original mainboard and two BTT EBB42 toolhead boards, controlled by the BTT Pad 7 over CAN bus. Aaand I think I just talked myself into also upgrading the heated bed to AC (that way I won’t have to get a separate PSU for the second hotend), replacing the bed springs with a fixed mount and I’ll most likely have to design and fabricate my own print head mount and probably customize and print cooling ducts too. Oh and I’ve never used Klipper, CB1 (or Raspberry Pi for that matter) or CAN bus before, and my experience with Linux is very limited. I’m making strides (finally got the CAN bus working on the Pad 7, that was a whole thing) but until it’s all set up, calibrated and tested I think I’ll let the KlipperScreen Update Manager bug slide :laughing:

Sorry, didn’t see your comment until now!
Yes, I did apt upgrade and it didn’t seem to make a difference. I think there’s something off with the BTT version of KlipperScreen that’s breaking the Moonraker Update Manager somehow. I suspect removing the directory altogether and doing a clean install from the official branch would fix it, but I need the BTT version for some functions on the Pad 7, like touch feedback. It’s not a big deal so I’m leaving it as is for now.

I did suggest apt update

I would try the brute force approach, Sineos suggested BTT Pad 7 KlipperScreen git repo error - #8 by Pritolus!