Cannot connect to mainsail using ip

Basic Information:

Printer Model: flsunv400
MCU / Printerboard:mks skipr
no log

Having trouble connecting to printer from mainsail ip address. Was working and installed a mks ips50 screen and am now not able to connect. Reloaded everything using kiauh and still nothing. Checked printer config and everything to have set to the printers ip but still no connect. Any help on placed to check or if I’m doing something obviously wrong . Board is brand new and doing initial setup

Hello @Jpierce !

Can you please tell us more on what system you have installed Klipper?

Do you have an old klippy.log?

Good luck, hcet14

Post your moonraker.log, please

Sorry yes running klipper, moonraker and mainsail

Ok, but I asked for the hardware.

The hardware is a Makerbase skipr board installed in a flsun v400 with an Makerbase ips50 screen

And where does Klipper run on?

Klipper is running on the skipr board, I am able to control klipper screen on the small screen via hdmi

And what is your host machine?

What do you mean host machine? There’s nothing else besides my computer connected

There is a 64 bit SOC on baord

1 Like

Could you give a lot more information?

  • What OS is running on your PC connected to MKS-SKIPR
  • How is the MKS-SKIPR connected to the PC
  • etc.

My pc is on windows 10 and connected through lan cable from router and computer is wired to router

Armblan 22.05.0-trunk with bleeding edge Linux 5.16.20-rockchipss

This is what’s running on the chip

Sorry I’m a bit new to getting a new board setup

Like this?

Me too. Are you able to connect to your SOC on MKS-SKIPR using SSH?

I’m able to connect via ssh no problem


When it was working, do you still have an old klippy.log?

Just reflashed the emmc with new image and now works. Should have tried from the start but thank you guys for the help it’s much appreciated

1 Like