Ender 3 V2 modified with direct drive extruder and BL Touch

Basic Information: BL Touch can not probe calibrate, printing only 2 mm over the bed.

Printer Model: Ender 3 V2
MCU / Printerboard: Creality V. 4.2.2
klippy.log Zip file

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

Dear Members.

I have earlier tried to have help in here for my used Ender 3 V2, at that time I was not the best user af klipper and this page, I am still not, but this time I have uploaded my klipper.log for my topic :slight_smile:

Month ago I bought an used modified Ender 3 V2 printer, it was fine and worked as it should at the sellers house (I saw this), he have made the printer modified with new fans, direct drive extruder, BL Touch and raspberry pi 3B with klipper.

Ohh my god, this should be my first printer with klipper, I bought the printer, was happy and went home. After a week or two I wanted to try my “new” printer. But still with out knowing about klipper, at the sd card from the Pi I could not find any file to change the netwaork access and then I was thinking - ohh the seller was using Linux, I use Windows, so maybe therefore - I have to make an re insatllation af klipper, as thinking the doing.
I have a lot of printers and now 3 raspberry pi’s, so I started to installing klipper at my own maschine Ender 3 V2 Neo original - and everything went fine and easy.
Then I started the klipper installation of the Ender 3 V2 bought used - all the installation went fine and easy, but in the end everything went wrong. For about 2 weeks now, I have been working with the printer and klipper, I have get help from other klipper users who have seen my printer.cfg file (not my klippy.log) and the have made a little change, but still saying everything at your files seems correct I it should work fine now.
I have connetion, I can home all, but when I follow the klipper instructions step by step and come to yhe point probe_calibrate the printer go to home all, the to it’s point at the right side of the middle and a little down under middle, the probe goes down, up and then move a little to the left and stop. If I try to make manually Z steps, the Z axis goes a little op and the return to it point before going up, when starting a print, everyhthing starts as it have to, but when i start printing the nozzle are up about 2 mm from bed and will not go down for making the right print.

What can I do and where do I have to change som setting for having my printer work correct with klipper.

Thank you for taking your time.

Best Regards


config-20230906-113126.zip (2.0 MB)

For a stock Ender 3 v2 with a Creality v4.2.2 board, your serial does not look right:

serial = /dev/serial/by-id/usb-Arduino__www.arduino.cc__0042_8543333323135161A110-if00

also the pins do not seem to match.

1 Like

Hello Sineos.

I’ll try look again :slight_smile:

Hi Sineos.

Thank you so much.
There the failure where, I took the MCU serial setting and copied from the printer.cfg to the klippy.log and now the printer can bed levelled to the bed and print at it.

You are big hero and you did a very big job at my printer farm.

Have a nice evening and weekend :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.