Ender 3 with btt skr e3 v3 board and cr-touch

Basic Information:

Printer Model: ender 3
MCU / Printerboard:skr mini e3 v3
klippy (4).log (4.9 MB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

…trying to run Klipper with raspberry pi 4b and mainsail. for two weeks trying to calibrate mesh. everythig else is running even the camera.

hdmi screen connected

getting gray hair and nervious breakdown from this . in Marlin everything was ok.
regards, albert

Hello @alfa !

Can you explain what problems you exactly have?

Error messages?

i can’t calibrate the z-axis. mesh test no good. printhead is digging in the bed. whe i try to calibrate mesh it stops and message “No trigger on probe after full movement” the z motor is trying to punch my bed with a lot of noise. my klippy log:
klippy (4).log (4.9 MB)
the print head is pushing the bed down.
regards Albert

this is my moonraker log:
moonraker (4).log (353.0 KB)

this is my printer.cfg :
printer (1).cfg (3.5 KB)

Prtinter is Ender 3 with btt skr mini e3 v3 motherboard and original cr-touch.

software is running on pc and hdmi 7" screen.


screen 7 inch

by the way…i am a radio amateur too . ON4AZC

and Münster is a great city. i have been there with the family. Grüsse Albert

Is your probe set at the right height? Are the offsets correct in your cfg? If you home z, can you touch the tip of the probe to make it trigger as it’s moving down, and does it continue to dig into the bed or does it move back up?

Closely and systematically check your config against the relevant example config here: https://github.com/Klipper3d/klipper/tree/master/config (mind your Ender model) and the relevant pin settings for the SKR E3 board also listed there.

I’d be very surprised if

rotation_distance = 4

was correct.


hey, thank you all for the info. first i changed [stepper-z] to rotation distance:8.thank you Sineos. then i started measuring the probe height. Thanks Zimmystar. seems that theprinted cr-touch holder was no good…probe too high. added some spacers at the probe lowering the height. 1 problem solved, printhead is not digging my bed anymore. still one problem now when calibrating mesh it stops after 4 steps…and generates an error: Move out of range: 236.000 32.000 10.000 [0.000]
can’t find what’s the reason…
So far so good, i am closer to a solution with your help. Greetz Albert
picture of hardware :

See Move out of range: X Y Z [E] for an explanation and Understanding X and Y Axes Limits and Homing for an approach how to define this correctly.

1 Like

thank you…working on it. mesh calibration succeeded :+1: now further investigating…meanwhile succeeded after many times try and error and reading i printed my first item (camera holder for rp 4 cam.

thank you Sineos! :+1: :+1: :+1: thread can be closed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.