Fine tuning extruder steppersetup

Basic Information:

Printer Model: Vcore31
MCU / Printerboard:Octopus Pro SHT42

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:

I have a RR Vcore 3.1 enclosed
As an extruder I am using an Orbiter 2 connected to an EBB42, but for some time I have been experiencing temperature problems, the Nema 14 motor of the extruder gets very hot, I don’t know exactly the temperature, I do know that you cannot touch it with your hands , and stop extruding.

I have tried to lower the current to 0.40, and with this something better, but even so it continues giving me overheating problems.

The engine is: LDO-36STH20-1004AHG(XH)

and the configuration I have for that motor, the one for the extruder is:

[tmc2209 extruder]
uart_pin: EBBCan: PA15
run_current: 0.40
stealthchop_threshold: 0
interpolate: True
sense_resistor: 0.11
driver_TBL: 0
driver_TOFF: 4
driver_HEND: 6
driver_HSTRT: 7

I’m not sure that the “driver_…” lines are correct.

Do you see anything that can be changed to prevent it from overheating?


I’m looking at options, meanwhile I’ve put a fan with plastic flanges… An option that I do not know if it would work is to place instead of a fan as in the PCS, a Peltier sheet …

What do you think?