Dudes how configure "spreadCycle" vs "stealthChop" in extruder

Basic Information:

Printer Model: Vcore 3.1
MCU / Printerboard: Octopus Pro+EBB42
klippy.log Not necessary

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:


I’ve had some problem, I think with the extruder motor overheating, and one of the things I want to check is if the driver (TMC2206) is configured correctly.

Right now I have this configuration for the extruder driver

[tmc2209 extruder]
uart_pin: EBBCan: PA15
run_current: 0.60 # antes 0,40
stealthchop_threshold: 0
interpolate: True
sense_resistor: 0.11
driver_TBL: 0
driver_TOFF: 4
driver_HEND: 6
driver_HSTRT: 7

I have read that for the extruder motor it is advisable to put it in “spreadCycle” mode, but I am not sure how to do that if:

A)-Setting it to 0, just as I have it (stealthchop_threshold: 0)


B)- Erasing the line (stealthchop_threshold: 0)

C)-A nother way…

The truth is that the lines: driver_XXXX, I don’t know where they are from, I think I remember that I copied them from some configuration… They are fine, it has the Orbiter 2 motor, I think a Nema 14 LDO

Are ok?


This means you are already in spread cycle. Spread Cycle is also Klipper’s default.
For the Orbiter settings see Orbiter v2.0 – ORBITER PROJECTS

How do you know? :wink:

#stealthchop_threshold: 0
#   The velocity (in mm/s) to set the "stealthChop" threshold to. When
#   set, "stealthChop" mode will be enabled if the stepper motor
#   velocity is below this value. The default is 0, which disables
#   "stealthChop" mode.

To keep stealthChop it always on, set the value to 999999

1 Like