Generate firmware

Basic Information:

Printer Model: sapphire plus 1.1
MCU / Printerboard:

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue:make menuconfig cannot edit. I’m totally new to the whole Klipper eco system but I’ve used the preconfigured Pi writer to install Mainsail. I’ve just reinstalled it because of the inability to edit the config file. The program loads a preconfigured file and only the first option can be modified, am I just missing out on how to select fields or is this another sort of problem? Mainsail seems to be working and I can navigate to the pi by ssh. I’ve put the stock printer.cfg by copying the example for the sapphire to a new file in the config directory.

Suggestions would appreciated.

Printer Model: Ender3v2
Printer Board: Creality 4.2.2
UI: fluidd

I ended up compiling mine on an octo pi version, however assuming its similar, when I ran the “make menuconfig” command, I was presented with a command line “gui” where I could use the up/down arrow keys and enter / left / right arrow keys to navigate and change options. The printer.cfg appears to only be used as part of the runtime, not as part of the firmware build. Good Luck!

Thanks Adam, that’s what is supposed to happen but I get a screen which can’t be edited. I tried octoklipper without success as well. Might be something to do with my internet I suppose.

I appreciate your input and support.

It shouldn’t be something online… are you dead set on octoprint? Having gone through the whole installer, I ended up using Fluidd. As an image its up to date (bullseye vs buster) and it seemed to have most of the needed libraries. If you have an extra SD card, you might try flashing a version of that and compiling on there.

Thanks Adam. I had reflashed with Mainsail and did all updates. The only problem seems to be with running make menuconfig which brings up a screen which I can’t edit. Perhaps I’ll try Fluidd or maybe wait for the next update to Mainsail.

This is quite strange indeed. The “GUI” should look like

Navigation is via curser keys, space bar and some letter short-cuts.
What do you use as your SSH client? Maybe some weird SSH shell thingy or your user’s shell is set to something strange.

You could try executing

sudo chsh -s /bin/bash <username>

With <username> apparently being the user you want to use for Klipper. After the command log off and back in to make the change active.

Thanks for the clue. After too much beating around the problem I found using Windows built-in Power Shell with SSH allowed me to edit the file. I’m ready to proceed, thanks to you and this community.