HALL ENDSTOPS: Not responding

Basic Information:

Printer Model: Delta Custom
MCU / Printerboard: MKS Smoothie

klippy.log (337.4 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

I have been moving all my old deltas to klipper and they are basically now all on the same board (I had some MKS 1.3 spare so they all got them).

The first machine used optical endstops and was a dream cut over
This second machine uses hall and has a small circuit board that looks like this

I know its wired to the right connectors etc as its the config is a copy of the previous working machine

The endstop leds light up when I manually home but query endstops shows no change

These were formerly plugged into RADDS/Arduino DUE which I have no knowledge of as they were built by different supplier and can no longer be contacted

I have tried adding the pullup ie ‘^’ and no change
Have also tried signal pin to gournd swap etc as per other posts on the forum

Any ideas? Its the only thing stopping the install as everything else is humming

Wouldnt let me post 2 attachments

Question: Are you using a SonicPad?

Yep…atm until they are all printers are running

Please take a note on the SonicPad:

BTW: The klippy.log of the SonicPad only includes error messages, but no copy of the printer.cfg and no other vital information.

Yeah I understand…and basically I have sent all other Creality stuff back except the K1max. The Sonicpad Im stuck with. Once I got my head round it…its been great and most of the errors I have got…have been my ie user error.
Just stuck on this endstop which I understand the klippy log deal now.
Anyway, I didnt know if there were basic issues I could chase

Im just setting up a PI on this machine now…so Ill send the log and learn something I guess :slight_smile:

Ok after much pain (SP might be crap but was so much easy to set up), I have now got PI3B+ running on this machine

Just trying to find how to find/set listening default ports on fluid/mainsail…whoah…ie there is only PI image with mainsail and when you install fluidd afterwards, you need a nasa course lol

New Klippy log attached here

klippy (2).log (81.3 KB)

So I have gone as far as I can go

  1. Upgraded and spent a day going through installing a PI instead of Sonic Pad but while it may enable visibiility of the config, it seems, according to documentation to be wholly related to mcu transaction; I can not see any data related to my endstop queries but maybe Im unaware of the finer details

  2. Have tried the pull/down options on pins. The logic inversion is of course irrelevant until I see some sort of active response at the klipper level

  3. Tried 3.3 and 5v jumpers on MKS board and tried the pull ups on that aswell etc

  4. If I check the signal pin coming from the hall endstop, on open, its sending 0.8v and when triggered its 4.7v

Im not sure why, in other posts, and forgive my newbness…why an active circuit would need a pull/down? Shouldnt the logic be clear?
Out of options but the endstops seem to be showing the led on at the appropriate home?

Remember they worked fine on the previous board combination. The leds still function correctly.

Any help greatly appreciated

I did find out these are a 3.3v. The volts on signal pin alternate between 3.3 and 1.7 on trigger/release
Not sure how to get that working

It would seem no one knows or is interested here…no problem
Any suggestions on somewhere to find help on this?


Hi All
Just in case there are any that actually need help on this…it was the motherboard all along. Some boards have issues with pullups etc. You can easily tell by connecting a multimeter and trigger the endstop. The status in eg Fluidd, should say triggered and the voltage needs to read either 3.3v OR 5v depending on the voltage/logic of your board, both will work and signal correctly
if the untriggered value is anything but 0v then the board is incompatible with the sensors. Pretty much all the older MKS boards are incompatible

I confirmed it by plugging in a BTT pico and everything…just about worked straight up…now for the new bug it introduced by going to this board…ARRRGGGHHH!

Thanks for all the help btw.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.