Heater Bed Temperature Acting Crazy

Basic Information:

Printer Model: Voron 2.4
MCU / Printerboard: FYSETC Spider 2.2
klippy (17).zip (1.1 MB)
Graph of heater_bed:

Printer has been working fine. Recently ran a number of long (8 hrs) jobs successfully. About a week ago, I started getting “ADC Out of Range” error. It was odd in that it wouldn’t show up until well into a print job. Thoroughly checked all thermistors and isolated the problem at the heater bed. Over time, the error became more prevalent. Now, it immediately throws ADC error upon startup.

I replaced the thermistor with a new one (tested with multimeter). Not luck. Moved to another port on the mcu (PC2 instead of PC0). No luck. Again, I tested the cable, resistor, and connectors. All still check out.

I have attached the klipper log here. I also attached a graph of the heater_bed data from the log. As you can see, it shows the bed temperature immediately oscillating and shutting down after reaching an unacceptably high temp.

I would think this was a bad thermistor, but none of my tests support this. I’m out of ideas. Any suggestions?

Hello @zig !

Why are you swapping between sensor_type = Generic 3950 and sensor_type = PT1000 in [heater_bed]. The PT1000 is a completely different fish and you can’t use that setting with an usual thermistor.

The temperature values with sensor_type = Generic 3950 look more plausible.

The thermistor that came with the heater (the one that failed) was a 3950. I replaced it with a PT1000, which I have also used elsewhere. The mcu documentation says the thermistor ports will accommodate a PT1000 directly.

As a check, I changed the sensor type back to Generic 3950 and hooked up one of those. Same results.

I tried swapping the chamber thermistor and bed thermistor in config. Same error. Now both are showing the same, very high (400 C).

It’s highly unlikely both failed in the same way at the same moment. Now I’m convinced it’s the mcu. Luckily I bought a replacement a while ago, just in case. Just need to hook it up and see.

Have you checked for the correct pull-up resistor value for the PT1000

Update: I replaced the mcu, and everything works great now.