Help with MCU 'mcu' shutdown

Basic Information:

Printer Model: Anycubic Kobra Neo
MCU / Printerboard: TriGorilla V_3.0.6
Host / SBC: Rpi Zero 2 W
klippy.log: klippy.zip (1.4 MB)

Describe your issue:

A few days ago, I installed Klipper on Raspberry Pi Zero 2W and since then, I’ve been experiencing a constant issue with the host disconnecting from the MCU. I’ve tried:

  • swapping SD cards(SanDisk 3U 64GB and 32GB, Samsung C10 16GB, PNY128GB) everytime reinstalling MainsailOS
  • changing all cables one by one
  • recompiling firmware.bin twice
  • switching power to different sockets
  • adjusting Baud Rate in printer.cfg

Nothing seems to help, and at random times, I get an MCU shutdown message.

The Raspberry Pi doesn’t reset; I can immediately click ‘Firmware Restart’ and the printer works again. Few times it printed big files, sometimes it shutdowns with calibration cube file. Do you have any idea what might be causing this problem?
I’ve run out of ideas.

Your Pi lost connection with your board for some reason.
The actual error was a “Got EOF when reading from device” which is described with actions to take below

1 Like

Thanks for your reply. I’ve done all that is in this post. I’ve changed all cables, power supply for Pi, tried everything, but it still gets to this error. I guess it’s a USB port problem. Hope it’s not.