Homing to -0.01

Basic Information:

Printer Model: Artillery SWX1
MCU / Printerboard: Atmel AtMEGA 2560 / MKS Gen L 1.0

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:

When I start a homing on X and/or Y axes both of them stops on Absolute -0.01 instead of 0. This means that is I move any axis with 100, I cannot move it after with -100, because it will be out of range. I tried to move the endstops without any luck, it always stops at -0.01. In the klippy.log there isn’t any valid corresponding information.
klippy.log (187.7 KB)

If you please share it.

1 Like

The endstop_positions, are they actually above the bed or a bit beyond?
And if yes, how much?

You may also set:

second_homing_speed: 10.0

For X and Y axes

1 Like

They are above the bed. Those are the physical limits of the printer itself exactly unfortunately.
Let me test the second homing speed, thanks for the advice.

Ohh man, you are the best! Thanks a lot the second homing speed solved my issue! :metal:

1 Like