Klipper on MKS Robin Nano V1.3

Hi all,

is there anybody out there using Klipper V0.10.x on MKS Robin Nano V1.3?
I can compile the firmware, I use the update_mks_robin.sh script but I never get Klipper/Moonraker/Mainsail to connect to the printer.

I tried flashing with Display disconnected. The file Robin_nano35.bin is converted to Robin_nano35.cur so I think it is flashed but somehow I do not get connection via USB.

I used this settings:

Strangely if I downgrade klipper to v0.9.1 and use

I can connect to the board. But if I try to compile my own firmware with v0.9.1 it does not work either.

Any suggestions what to do or how to debug this?



I feel dump.

I just had to flash out/klipper.bin WITHOUT using update_mks_robin.sh

Do not know why but it seems to work.

Maybe this thread helps someone else :wink:

1 Like

I am facing the same problem at the moment with my new sapphire plus

Could you tell me how to flash out the Klipper.bin?

I do not really know how to do this


cd into your klipper folder,

run make menuconfig and select these settings


After running “make”, FROM THE KLIPPER FOLDER:

cp out/klipper.bin Robin_nano35.bin and copy the file Robin_nano35.bin to sd card, put sd card into your printer and turn it on.


Absolute life saver - i was stuck for HOURS in a loop of not knowing why things were failing.
Maybe that script is intended for the 1.2 board? Its my guess.
It all works now. Thank you

Hello, I don’t actually want to use the screen, but the firmware does not accept it. Do you know the screen pin code, GPIO?