Klippy not connected? after updates

Basic Information:

Printer Model: Ender3 V2
MCU / Printerboard: Rasberry PI

Yesterday in Fluidd I saw some updates, so I run the updates, after that it is not work anymore.

on the Webpage Fluidd I see Klippy not connected. But I don’t know how to fix it…?

I looked with kiauh, but everything shows alright… I checked with putty the USB connection with the Ender printer, and that’s also okay… ? but it still not works… so help!!! :slight_smile:

And the klippy.log is where?

is also not working? If i press the klippy.log button, normally I get the download menu, and the log files were in my download folder, but now if I press the button I get a 404 screen?

    "error": {
        "code": 404,
        "message": "Not Found",
        "traceback": "Traceback (most recent call last):\n\n  File \"/home/swets/moonraker-env/lib/python3.9/site-packages/tornado/web.py\", line 1713, in _execute\n    result = await result\n\n  File \"/home/swets/moonraker/moonraker/app.py\", line 734, in get\n    self.absolute_path = self.validate_absolute_path(\n\n  File \"/home/swets/moonraker-env/lib/python3.9/site-packages/tornado/web.py\", line 2813, in validate_absolute_path\n    raise HTTPError(404)\n\ntornado.web.HTTPError: HTTP 404: Not Found\n"

I get this

You tryied this?

The Klipper log file is located in /tmp/klippy.log on the Klipper “host” computer (the Raspberry Pi).

maybe I can copy it with WinSCP, but I can’t found the folder…?

I think I found it, but how do I upload it here? (sorry…it is all new for me…)

Yes, just use


to upload to your next post.

If it is too huge, you can zip (compress) it.

klippy.log (5.1 KB)
I hope I did it right?
and is this the right logfile?

That log looks quite wired.

One and the same report - 10 times. But no error message.

It seems Klipper does not run at all.

and how do

how do I check that? this is what I see in Fluidd

i have also Mainsail …

Mainsail and Fluidd can’t connect to Klipper because Klipper is not running.

I suggest to reinstall the whole thing.

:slight_smile: yes but how? just look at kiauh…

so, with kiauh delete klipper, and after that instal it again?

I never used kiauh.

I can’t say.

Maybe retry updating Klipper can fix it.

Would be nice if kiauh would have a repair feature.

okay, I go try… thanks!!

I am in the same situation. Did you manage to fix it and how?



He just tried 14 minues ago!

yes, it is working again…

with Kiauh, first, I remove Klipper, and after that, I install it again, and now it is okay?

1 Like

You have to try to see.