MCU shutdown and prints fail

Basic Information:

Printer Model: Sunlu S8 Pro
MCU / Printerboard:Stock? Sorry can’t remember
klippy.log (1.0 MB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

…All my prints fail midprint and the mcu shuts down due to webhooks. I have no idea what else to try. Please can someone look over my log and see what is messed up.

Are you using a Creality Sonic Pad or something like that? Creality Sonic Pad and Alternatives
There is no real Klipper version visible and it looks different to me.

However this is your main issue:

Transition to shutdown state: Lost communication with MCU 'mcu'

Could be a bad USB cable or contact.

Using sonicpad. I’ve tried multiple cables and changed ports, does it every time. Incredibly frustrating. My friend configured it for me and it has made a few successful prints before doing this and it makes me think it’s working and printing for a bit before crashing. My friend can’t tell me what’s wrong and it was working fine for him.

We do not really support the SonicPad here but maybe you can upgrade it to the latest firmware.
Here are quite a few cases where the USB cables caused such errors.
Use as short as possible cables with good shielding. Maybe a good USB 3.0 cable can do the trick.

I’m thinking of giving the pad back to my friend and using a pi. The pad is notorious for bad usb ports. It is on the latest firmware. I updated it after my friend gave it to me…I’m wondering if the update caused some issues if it worked fine beforehand.

You are always free to contact the Creality support.
But using a Pi and maybe a supported screen is not the worst idea!

It says: “Never change a running system” for a reason. Updates can make things better or worse, depending that you don’t want at the moment… :smiley:

Sadly the moment I mentioned that the printer I’m using is not creality, they immediately didn’t want to help.

Regardless if Subsonic Pad or not, the reasons for this error and potential solutions are described here; Timeout with MCU / Lost communication with MCU

“Subsonic Pad” - was that a Freudian slip?

To my own defense: Of course, since I’d never intentionally make fun of this fine product :innocent:

Guess Freud would find this thing very interesting and probably assign it to the anal-sadistic stage of adolescence. :man_shrugging:


Why wouldn’t it immediately disconnect if it was a faulty connection? It makes me wait 20-30 minutes before shutting down.

Many reasons:

  • Movement
  • Vibration
  • Thermal stress
  • etc

Depends on the actual root cause.
Remove everything unrelated to printing, e.g. webcam, USB hubs etc.
Otherwise, refer to the potential causes in the a.m. link.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.