Newbie needs help to flash back to marlin from klipper to sell printer

Basic Information:

Printer Model: sidewinder x2
MCU / Printerboard: ruby 32

Hey all I’m a massive newbie to klipper and flashed it to my sidewinder x2 via printer face and prusua slicer.

After a steep learning curve all is well, but I need to flash back to marlin to sell the printer and then get a core xy and re flash klipper.

But when I try and flash marlin using the same methods I get an error in printer fscr of “rubbish reply” Google tells me that it’s down to fact there’s no firmwear as such on the board.

Can someone please tell me what the process is to flash back, but treat me like the idiot I am :slight_smile:
Thank you


This page (Downloads) from the artillery downloads page has all of the different firmware’s available. Just chose the one that fits your printer, (if you havent upgraded the screen or hotend, it should be: Artillery Sidewinder X2 Firmware (stock, bin) ). Download the file from their google drive, then rename the file to firmware.bin, put it on an sd card, and put it into your printer card slot. After a couple of minutes, take the sd card out, and reinsert it into your computer. If all went well, the file should now be named FIRMWARE.cur in all caps. Marlin should now be flashed to you printer’s mainboard again.

However, because of all of the hype about klipper recentally, and the Sidewinder x2, it might make more sense for you to keep klipper on that printer, and help the people get it set up to their network, ecterra, ecterra. Reason being, you might be able to get a bit more out of it. But its your choice. Here is a video about marlin setup in case you would like to create you own configuration. Ender 3 V2 - Marlin Firmware Upgrade - 2022 - Chris's Basement - YouTube

Happy Printing,

1 Like

Thanks for the reply.

Not gonna lie if the cost of a pi wasn’t sky high (I’m a poet) I’d have sold it with Klipper enabled but… I want to keep it myself lol.

Thanks for the advice, so… I followed what you said, downloaded the right file and renamed it firmwear. Bin

Popped it onto a 1gb SD card and turned on the machine, each time I checked, it hadn’t changed the file name, I tried it with nfts, exfat, fat and fat32 formats but each time it was the same.

How long does the flashing take? I take it out long after teh screen has booted up?


I agree, I wouldn’t sell it either, I am using the BTT CB1, and it is working for me so I didn’t know if you were using one as well, or using a pi. When I previously used Marlin, it had some issues flashing, and it was very picky, i’ll list them here.

Before doing anything, make sure that your pi is unplugged while flashing Marlin. Klipper is mainly run on the pi, and it kinda takes over the mainboard when klipper is running. So maybe when you are flashing, the pi may be interfering in some way, making it so marlin can’t flash. Basically what I am saying is, the pi may be bossing around the mainboard telling it not to flash, and as a result, Klipper is not flashing.

I first noticed that you spelled it firmwear.Bin There are two problems here, first problem: For some reason programers decided spelled it firmware, with the last 4 letters being WARE instead of WEAR. I got confused by this at first too, thinking that it was spelled with the wear like, “I wear my clothes.” But it is not, it is spelled like ware. This is an easy mistake to make, so I don’t blame you. Just spell it “firmware.bin”, and you should be fine. Second problem: You also said in your response that you named the file with a .Bin, a capital B in bin will mess this up, all lowercase is the way to go. This could have also just been a typo on your part, so. . .

If that doesn’t work, try unplugging everything from the board. I know, it sucks, the same BTT Octopus that didn’t like my se card wouldn’t flash unless everything was unplugged from it for some reason. So, if you still cant get the firmware to flash without naming the file correctally, try this, but only try this as a last ditch effort.

One last thing. Your sd card may be the problem, I had a btt octopus that didnt like too big or too small sd cards. People generally say to use 16gb cards for flashing marlin, but if you don’t have one it’s probably one of the other things I listed. If nothing else works, I would buy a couple of different size sd cards (16gb, 32gb, and 64gb, (if you don’t have those size’s already)), try not to destroy the packaging, and find the one that works. Then return the rest. Only try this as a last last ditch effort.

Another idea, If none of this works and you have lost hope. Buy a CB1 and it’s companion board for about 55 to 60 bucks on amazon, and use this amazing tutorial to set it up: BTT - Manta M8P CB1 Install - YouTube, (I know that this video tells you how to setup a CB1 with a Manta board, but the process for a Manta board and the CB1 companion board is exactly the same). Then simply copy all your config files over to the CB1 from your pi interface. This would eliminate the need to flash marlin if your still having issues, and it would be pretty cheep. I also think that you would be able to make the money back. Also, transferring the files couldn’t be easier. Just right click on each of your pi files, download them, and then when you want to put them onto the CB1, just hit the upload file button, select the files, and put them onto your new board.


  1. I hope that this helps you flash marlin onto your board, and gets it sold.
  2. It really shouldn’t take more than a couple seconds for the flash to occur, just set a timer for a couple of minutes after you power on the board -after you insert the sd card- and you should be good.
  3. I believe that your only problem is the “misspelling” of fimrware.bin. And the pi, make sure you unplug the pi.

Happy Printing,

@Blake100 The term “firmware” is a very old expression in the embedded world. We are born the same year :rofl: Firmware - Wikipedia

Thanks for the reply.

The spelling and the capital B were both sloppy posting errors late at night, the file I’m trying to flash was spelt and formated correctly.

I had the Ethereal Project flashed to the machine prior to klipper, so had a different screen FW, I used the same SD card to flash back to the stock screen and that worked without an issue at all.

So the cards good, the spelling and formatting is good, the files right.

Do you really think what’s stopping it now it it needing to be unplugged? Or shall I say everything unplugged from it.

Thanks again


It is possible, if you still are having any problems. Have you made sure to unplug the pi? And if that doesn’t work, then yes, I would try to unplug everything else from it. Other than that, are you flashing the board from an sd card attached to the screen, or are you plugging it directly into the board. If you are plugging it into the screen, there may be something else blocking it. Klipper, for instance.

So, all in all. Pi unplugged, make sure to plug sd card directly into the board, not into the screen (I really have no idea about this machine at all except for watching maker mues’s video, so if there is no sd card slot on the screen, forgive me). Then if nothing else works, I guess try to unplug everything, and hope that it works. Other than that, there is nothing else I can think of currently, but I will let you know if anything else occurs to me.

Happy Printing,


Well, I do hope that I didn’t mislead you too much. Out of curiosity, I looked up how to flash you sidewinder x2, and this video: How to install firmware on your Artillery 3D printer equipped with a RUBY mainboard. - YouTube explains exactly how to do it. Apparently there is a stupid thing that the ruby mainboard does, that most mainboards don’t do, and that is you manually have to put it into dfu mode, which basically means that it is ready to receive new firmware. So, try to follow the video, it seems like it involves installing a couple of programs, but seeing as he has the exact same stuff as you, it seems like a good idea to follow his advise.

I also want to say that I am sorry, as it seems as though I lead you on a wild goose chase. Because, nowhere in the video does he mention using an sd card to flash firmware. Please try to ignore my last post, and try this first. But don’t forget, unplug the pi.

Happy printing,

Ah yes now this is perhaps where my first post could have been a little more clear.

I’ve tried that way to flash the etherial project before klipper and it worked fine.

But now I have klipper on, trying to flash the same way gets me an error from pronter face saying “rubbish reply, maybe a bad baud rate” turns out that error is thrown up due to the fact the board doesn’t have any FW Installed.

So I’m a bit struck.

Ultimately I’ve struggled with klipper, and was 50/50 keeping it without klipper despite the fact klipper is far superior in the things I have managed to get done.

I’m conflicted

You can’t connbect with printerface to a Klipper configured printer like you connect to a Marlin printer.

Klipper Runs on the Pi (or what ever) and the printer and uses the USB for it’s own purpose with a different protocol.

Maybe this helps:

Thanks eddy
I’ve run that script and klipper no longer works on the GUI, so I assume it’s removed

Unfortunately I’m still getting the pronter face errors when trying to get it into dfu to flash (or trying to flash without using prusa or even the SD card method)

Does this mean I can’t now revert this board back due to how artillery have made it?


It’s possible that that’s the case, I really am at the end of my klipper knowledge. The thing I would do if I were you is to get a new mainboard (3djake has one for 40 usd). Or buy a btt cb1 and its compainon board like I said earlier.

From what has been said here, it seems as though artillery ruby boards are finicky, and if that is the case, I really don’t know if there is anything else I can do to help you. However, you said that you are going to get a corexy. I don’t know what one you are getting, but I assume that you are going to get a kit and build it. If I were you, since a corexy is already expensive already, I would leave a board out of the kit you are buying, accept the loss of the pi, and restore klipper onto the ruby board. Then I would sell it, and for the corexy, buy a btt manta board with a cb1. This will set you back only a bit more than using an octopus or whatever, and is definitely more seamless. I am using it with great results. It is also supported by Ratrig’s ratos, if that is the route you are going. Voron’s are typically more “find you own way around things” as they don’t provide any special firmware from what I know, so firmware compatability isn’t really an issue if you are going to get a Voron.

I will keep my brain thinking, and will respond if any new information comes my way.

Happy Printing,

Thanks Blake I’ll restore klipper and go that way, I appreciate all the help.


Your welcome. Sorry I couldn’t be of more help. If you have any problems with a cb1, I’ll be happy to help if needed.

Happy Printing

I see this post is from the same time I had problems with my Sidewinder X2, that I had bought in December.
I wanted to revert to stock firmware (from Artillery3D website) , it should be easy according to many (older writings found on the net).
Pronterface connect attempt also returned: ‘rubbish returned com port’.

I unscrewed the bottom and put a jumper on the artillery ruby 1.2 motherboard between boot-3.3v (described here: Reddit - Dive into anything)

But this lead to a non recognised USB port when I connected the printer to the laptop.

Then I read somewhere to download the latest vcp drivers from VCP Drivers - FTDI
The latest executable for windows installed nicely and when I plugged in the usb, the printer was recognized as a usb-dfu-device.
I used stm32 cube (from artillery website) to flash the stock binary without having to run pronterface. It worked like a charm.

I think you already sold your printer, but if someone else might want to decide to revert back to marlin on a sidewinder x2, here it is :slight_smile: