No space on sd card - partitions

Hi all,

I am trying to install Klipper for the first time in my Ender5 with a new motherboard BTT SKR mini E3 v3.
When I use Raspberry image to install the OS (I’ve tried both Mainsail OS and Raspberry OS) it creates 3 partitions on my SD card. The OS is install in a 5.5Gb partition leaving about 26Gb of unallocated space (32Gb card). Because of this I don’t have enough space on my card for anything. I can’t update, I can’t add files to print. I’ve tried to install from zero and it even told me there was not enough space to install klipper!

How can I stop Raspberry Image creating those partitions? I can’t believe I am the only one with this problem. I have checked lots of tutorials and none of them make mention of this problem. I have search on Google and I can’t find any solution to this! It really looks like something Raspberry Image does as standard so it should be a common problem.

Thank you for your help.

I’m not sure what you are reporting.

Depending on Linux distribution, hardware and user choices during setup you will have commonly (for the RPi: always) two partitions:

  • One boot partition that is usually a FAT32 partition. This is only used during the boot process and serves multiple purposes like
    • securely booting the device
    • loading drivers
    • tweaking boot settings
    • handing over to “main Linux” once booting is done
  • One root partition that holds all the rest (basically C:\ for the Windoze minded)

On a RPi it typically looks like this:

$ lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINTS
mmcblk0     179:0    0   15G  0 disk
├─mmcblk0p1 179:1    0  512M  0 part /boot/firmware
└─mmcblk0p2 179:2    0 14.5G  0 part /

Then the OS creates a number of virtual file systems for various purposes, but they are not persistent.

AFAIK, the modern RPi distribution should automatically expand their root file system to the max available of the respective SD card. If not, one can typically use the sudo raspi-config to do so:
6 Advanced OptionsA1 Expand Filesystem

RPi was creating three partitions instead of 2. The ones that you said and one big unallocated partition with nothing in it.

After reinstalling the OSx about 10 times it has now stopped doing it. I have no idea why or how. It has done it many many times, every time I tried to reinstall it, it was creating that third partition. Now I’ve tried again and it hasn’t done it.

So I guess my problem is now solved but I still don’t understand why RPi was doing that.

Raspberry Pi OS based system only create two partitions.

The root partition gets enlarged on first boot - so if you checked the partitions directly after flashing MainsailOS it was not expanded yet

Unallocated space is not a partition. It is just unallocated space. No idea what went wrong on your side.

It was still doing it after installing Klipper, Mainsail and Klipperscreen and using it for a couple of days. I only noticed because I added a couple of files to print and suddently the card was full.