Setup SKR Pico with Pi Zero W

Basic Information:

Printer Model: Ender 3 pro
MCU / Printerboard: SKR Pico with Pi Zero W

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue: So… I’ve had a number of issues trying to get my ender 3 running after a thermister issue… which led me down a very long and expensive road to get to this point! :smiley:

after asking the ahem helpful people on reddit i thought it made sense to come here instead.

Basic issue… I’ve installed mainsail on my pi zero w, can connect to the web interface fine. I am connecting the pi zero to the SKR pico via UART… I can’t clarify which port it’s using either ttyAMA0 or ttyS0… also for some reason the klippy.log shows it cant find the printer.cfg file in the directory it is in?
moonraker.log (255.8 KB)
klippy.log (410.9 KB)

I added the moonraker.log too… hope it doesnt have anything it shouldnt in it…

anyway… I’ve also tried kiauh which seemed to get me to the same point.

Any ideas would be awesome… been at it for 2 days now…just on the setup side of things… I used NERO 3D’s video for inital set up so i know it should work…

Thanks in advance! (hope its in the right place!)

Post the content of your config.txt and/or usercfg.txt and/or syscfg.txt and/or cmdline.txt file. The files can be found in the /boot or /boot/firmware. Which of them exists and where depends on the Linux flavor you are using.

cmdline.txt (80 Bytes)
config.txt (3.2 KB)

I thought it may be easier attaching them, I’m using mainsail os… i actually tried it with a pi 3b and it still didnt find it

these were the only 2 files i had out of what you mentioned

I may just start again from scratch as I’m sure i’ll have messed it up somewhere

Your settings are looking good.

  • What is the output of ls -l /dev/serial*
  • You are using GPIO 14 (pin 8 / TX) and GPIO 15 (pin 10 / RX) of the RPi?
  • You are correctly connecting RX / Pi to TX / MCU and vice versa?