Klipper configuration file not located in 'config' folder

Basic Information:

Printer Model: sunlu with ender 4.2.7
MCU / Printerboard: ender 4.2.7
klippy (21).log (309.3 KB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue: i have an ender 3pro running the same hardware and firmware with no problems but i am getting this error msg only on the sunlu machine

i dont understand

Do I understand correctly:

You unplugged the Ender from the Pi (or where ever Klipper runs on) and plugged in the Sunlu?

both have their own pi
identical mainboards and firmware…

also now having trouble getting the endstops to behave…
typical config adjustments have no effect
z functions
x registers in reverse no matter what changes i make in the config
y reads as triggered no matter what changes i make in the config.

1 Like

Are the MCU boards identical as well? soind like you have a pinout issue. Also, did you flash the MCU’s and checked if the USB ID’s are different? Cheers Florian

i reflashed the sd card and i can now connect, and the x and y axis are behaving normally,
i have alot of policy kit warnings but every time i update them in ssh or even do the updates using the settings page, i lose all the config files and cant drag and drop anything into the list…
also the z axis end stop works but the motors just buzz when i try to home.
also moonraker disconnects when i try to heat the nozzle, the bed heats fine but the nozzle no.
i am going to open another disussion if i cant figure it out tonight.
moonraker (5).log (185.6 KB)
klippy (22).log (839.2 KB)

once i get the bad gateway error its a stone wall. i cant connect again to undo or edit.

This seems more like an issue with Moonraker / Mainsail or Fluid
How do you install them?

The 4 functioning ender 3pro’s were flashed with balena etcher

I tried that with this sunlu/ender4.2.7 and it is buggy

I tried using the kiauh method and it was too confusing on the final steps.

Fluiddpi19.Something flashes but then shorts out and empties the config file list, (or gives the bad gateway error) when i update it or fix the policy kit warnings.

It is not recommended to use the fluiddpi distribution. It is no longer maintained and there are reports about issues.

You have following choices:

thank you. i think my problem with kiauh is i dont want mainsail.
is the a guide for kiauh and fluidd?

  1. Get and etch latest Raspberry Pi OS
  2. git clone https://github.com/th33xitus/kiauh.git
  3. Run kiauh
  4. Choose install
  5. Install 1, 2, 4

massive progress. i followed your instructions and it is connecting.
i did not do the os update because that caused problems in the past.
i am currently chasing wiring issues with the dual z steppers and
the hot end but that is easy now that i have a stable connection!

thank you Sineos.