Temperature issues

Basic Information:

Printer Model: Vcore 3.1
MCU / Printerboard: Octopus pro + Sht42

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:


I have had the Rapido v2 Hotend installed for some time… until now I had only printed PLA, and PETG (a little), but yesterday I tried to print ASA, whose printing temperature is about 250, according to the material manufacturer…

Well, when I printed, the material came out VERY liquid, and halfway through the print it stopped extruding…

The first thought was a thermistor breakdown…

I thought that these problems were due to temperature, so with a thermometer with a (kitchen) probe I checked the temperature that Fluidd told the Hotend to heat up and the temperature that the hotend actually reached (with the error inherent to the measuring device).

And I realized a couple of things:

When the temperature that I sent was about 195 degrees (I usually print PLA at that temperature), the real temperature (with error in the measuring device) is quite similar, 205.

But when the temperature that I told it to heat up is 245, the real temperature is about 270, that would explain why the ASA came out so liquid.

The higher the temperature, the greater the difference…

I thought it could be a temperature calibration problem, so I tried to calibrate the hotend temperature at 255º… but it gave me an error, the first thing I noticed was that the temperature rose somewhat slowly, but when it reached the target temperature , it gave me an error because it was not raising the temperature at a sufficient speed… normally, I was telling it that the goal was 255, when in reality it would be approximately 280…

So I consider two possibilities:

  • Damaged thermistor…
  • Thermistor incorrectly configured, I have it configured like this:

sensor_type: ATC Semitec 104NT-4-R025H42G
pullup_resistor: 2200
control: pid

Is there any way to check the thermistor?
How should I proceed?

The solution I found, provisional, is to print at about 225 degrees, which is 245 degrees, and calibrate at a temperature of 240…

You cannot simply combine and mix sensor_type and pullup_resistor, hoping a halfway correct temperature reading comes out of it.

Both settings depend on your hardware and there is only one truth. As most of the boards, also the Octopus Pro is using a pullup_resistor of 4700 and you cannot use any other value.

As a first step, identify without any doubt the exact type of temperature probe you are using in your hotend. No guessing, no maybe, no “uh, I have no clue” but the exact type and then we will continue from there.

1 Like


i have a Rapido v2… connected to Canboard (sht42)

and i have configured…

heater_pin: SHTCan:PA8
sensor_pin: SHTCan:PB0
sensor_type:  ATC Semitec 104NT-4-R025H42G
pullup_resistor: 2200
control: pid

I cannot tell if ATC Semitec 104NT-4-R025H42G is your correct sensor. At least the pullup_resistor seems to match for a SHT42

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.