Closed printer not extruding

Basic Information:

Printer Model: Vcore 3
MCU / Printerboard:Octopus Pro + SHT42
klippy.log (5.9 MB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:


I know this is not the most appropriate forum, but I don’t know what to try anymore or I have no idea what the problems I’m having may be.

I post it in this forum because there are people with great experience in 3d printing and they can give me some idea, or some test that I can do.

It is a closable CoreXY printer, I prepare a model, I have tried several slicers, but I am using Slic3r because it has a profile for that printer, and it has never given me any problems.

One piece, only 1, not very large, cylindrical, 3 cm in diameter and about 15 cm high, in PLA 196/65.

I send it to print, when it starts to print, while I adjust the ZOffset I keep the printer open…2 or 3 layers. At that moment I close it, because in a variable time, less than 2 min, it progressively stops extruding, until it stops printing.

I have tried many things, including changing to my old hotend, raising and lowering currents, speeds,… many tests. But I can’t find out why with the printer closed it stops printing.

What can I try?
Does anyone have any ideas what it could be?

You have some

MCU 'SHTCan' shutdown: ADC out of range

errors in your log.

Please be more specific:

  1. Does the extruder simply stop extruding? OR
  2. Are you getting an error message?

From your log, my guess would be #2 and this could mean

  • Faulty thermistor on the hot end (wiring or thermistor itself)
  • The board does not like the increased temperature caused by the enclosure.

I usually print ASA, PC and similar filaments, so always with a housing. This is exactly the reason why I do not use CAN boards, as I cannot keep them away from the increased temperature and the components on the CAN board like it cool rather than hot (apart from the fact that it increases the complexity quite a bit → more things to fail).


Your issue is absolutely typical for printing PLA in a closed enclosure. PLA gets soft at ~50°C already. As soon as you close the enclosure, the temp inside starts rising, causing the cooling to the heatsink to become insufficient, so during a retract, the PLA remains too soft as it is pulled up and then gets stuck in the heatbreak and extrusion fails completely eventually.

Don’t print PLA in a closed case, simple as that.

On a side note, I run a SHT36 CAN board in a closed enclosure just fine, inside temp ~45°, CAN board MPU temp is about 78°, no failures even after 4+ hour long prints.


While I fully agree with you @Arakon, this does not explain the “ADC out of range” errors.

Adc out of range is that it can be and has nothing to do with heat creep problems. It was my fault…

One of the times I turned on the printer and had the temperature sensor and the Heat sink fan connected upside down

As usual, the problem I think is simpler than it was supposed … Or so I think.

The solution I am using is to lower the temperature of the bed about 30 degrees, doing this seems to get the filament, when close chamber, does not reach the transition temperature …

This, at least today has worked, that the temperatures 7am dropped about 15 degrees, maybe it has had something to do with it

Thanks for tips, they give me ideas