TMC 'extruder' reports error: GSTAT: 00000001 reset=1(reset

So have had this happen tree times in a row now. Tried re-slicing, updated to latest klipper, and atm testprinting with swapped cable with theY axis one.

I’m reading it most likely could be wiring, voltage or steppers. And also seeing that it could be PA related, and in one case usb related. (Will change mine if happens again)

This is a brand new SKR E3 Turbo card, with integraded 2209 steppers.
Voltage has not been tuned anything. Should i?

Ender 5 Plus (1.2 MB)

Tried switching to E1 driver, but still same error. Swapped stepper cable with Y, but still same.

Now i have replaced the stepper motor with new one, and instantly running longer, for now tho. Still only hours into a 16 hour print tho…

Stepper voltage.
Ehm i running it a little low?


run_current: 0.650
hold_current: 0.500

You do net set voltage but current.

You need to look up your motor specification in its data sheet. Following two cases

  • Current as Peak Current: Multiply by 0.707 to get RMS and then by 0.85 as safety margin
  • Current as RMS: Multiply by 0.85 as safety margin

Often it is not clear from the specification if it is Peak or RMS. If in doubt contact the manufacturer

Yeah sorry, of course i mean current. My bad

Yeah its just standard Creality 42-40 steppers.

Kinda wanna hear what people are using on theyre machies. On a Ender 5 Plus here.

stepcompress o=6 i=0 c=4 a=0: Invalid sequence
stepcompress o=6 i=0 c=4 a=0: Invalid sequence
stepcompress o=6 i=0 c=4 a=0: Invalid sequence
Exception in flush_handler
Traceback (most recent call last):
  File "/home/pi/klipper/klippy/", line 392, in _flush_handler
  File "/home/pi/klipper/klippy/", line 337, in flush_step_generation
  File "/home/pi/klipper/klippy/", line 175, in flush
  File "/home/pi/klipper/klippy/", line 333, in _process_moves
  File "/home/pi/klipper/klippy/", line 286, in _update_move_time
  File "/home/pi/klipper/klippy/", line 191, in generate_steps
    raise error("Internal error in stepcompress")
error: Internal error in stepcompress

looks like this is the real error. I’ve seen this when people have microsteps set to 32, but you don’t so I’m not sure.

1 Like

So i did swap driver, cable and so on… I did end up changing the stepper to, and then things started working again. Have been printing 24/7 since then, and still good. I even seeing improved result in flow for sure! So, guess it was a bad stepper. Even being brand new.

I’m having the exact same issue, on the same brand new E3 Turbo BTT board. Weird.

I have tried everything but changing the actual stepper. guess that’s next…

Yeah, on the extruder for you to?

Also try changing the usb cable, if using one.

No, it’s usually stepper_y that’s reported, but sometimes stepper_x, y and z are reported, even though it always happens on y (only) moves in my testing.

Ohh dang Hmm… Yeah that sucks!

Ohh man, yet another error now! :frowning:

Looks the be reported on the extruder again!?

The wierd thing is that i was opening mainsail on my PC, it was in pause mode due to filament change, ok so i go to change, pull out the filament and insert new, and then open mainsail on my phone, just to suddenly see that it throws error.

So the only thing i did between those steps was to pull the filament out of the fiament sensor, and insert new…
I guess i also could have manualy turned the extruder gear while doing so, due to frition, but i dont know…

Could this actually have been sent som wrong signals due to this, to mess things up?

Wierd :confused: (64.2 KB)

My solve…sensorless homing. It turned out to be a faulty endstop that was causing a short

1 Like

Oh really?.. Hmm.
Yeah i have tried removing the filament sensor, and still no error since then.

Best guess? Creality peripherals are cheap and faulty

1 Like

I’ve started having the same issue pop up quite regularly over the last couple of weeks… When I change filament during an m600 pause for color change.

I’ve noticed that when I touch my extruder to remove the filament, the gear occasionally “jumps” about 3 steps, at which point it always fails with the GSTAT reset error. :confused:

I’m going to try to replace my stepper motor and see if that helps.

On the bright side, I’ve become VERY adept at rescuing prints that fail this way :sunglasses:

“Good to hear” it’s a similar cause. I tought it was the same here, so stepper was replaced. But leaning more on the filament sensor now. Or, the port in the card in witch the filament sensor is connected to.

I really should try a different port for the filament sensor, but not gotten that far yet.

Do you use a filament sensor? If so, did you try to disable it or not use it?

Also what printer and card are you running?

I don’t use a filament sensor.

I’m using a modified tevo Tarantula with an skr v1. 4 turbo and 2208/2209’s…

The weird thing is that it JUST started happening last week (and I do a LOT of printing with this unit, as it’s my best tuned printer)… But once it’s started, it’s happening pretty frequently :confused:

Joining the party! I’ve also been suffering from this issue for around a week now. After battling with oval circles and parallelogram squares for around a month due to a dodgy stepper motor (of course it couldn’t be that simple! - it was!). I fix that and of course, another problem rears it’s head! I swear this machine is cursed!

I get the GSTAT error on every motor, not just the extruder, but it’s clearly the extruder that triggers it. During my testing, I ran some prints without filament, mostly to save wastage. When the extruder motor isn’t under load the Gcode runs flawlessly. I’ve modulated a bunch of config parameters in my quest to exorcise the demons: Stealthchop off on all motors, all the microstep settings, disabled interpolation and tried different current settings (lowering e current seemed to alleviate the issue - prints would run longer before failing - but the problem persists). I tried a bunch of different print speeds and lowered acceleration - no dice. I’ve also tried switching to UART interfacing with the Pi as this seemed to solve the issue for others, alas, not me.

I’m also running a BTT E3 Turbo. It’s been fine for a couple of months running on Marlin so I’m doubting it’s the board. I first ran into the problem after adding a large number of cooling fans, they’re running from the second extruder heater output which should easily be able to provide enough amps. I don’t this is the cause but I’m noting this for posterity.

The next thing I’m going to try is re-crimping the JST connections on my extruder motor cable. The connections are all clearly made or the motor wouldn’t run but late last night I examined them and despite being solidly attached to the insulation of wires, the female ends possibly don’t have a great deal of surface area of contact with the bare conductive part of the wires which could be resulting in poor conduction. I’m clutching here but until the replacement e motor shows up it’s all I got.

I am on the same boat it seems. Very similar issues to what @Lionel_Glitchy described. Random steppers reporting the reset SKR E3 Turbo board as well. Printer worked ok with Marlin previously. Tried all the troubleshooting others have described again to no avail. Just replaced the power supply with new one, but that didn’t seem to change a thing either. Next step is seemingly go back to Marlin to see if printer behaves.
klippy (8).log (1.8 MB)
Attaching log if that helps

I was having a similar issue. The resolution appears to have been a cable or two may have been loose and moving slightly during the print which may have created issues with the electrical signaling.

I hot glued all the connections on the board. Any other connections (e.g., fan wires connected with Dupont connectors) were replaced with soldered connections to make sure they are firm and unable to move during prints.