Transition to shutdown state: MCU 'CB1' shutdown: Stepper too far in past

Basic Information:

Printer Model: Custom
MCU / Printerboard: Bigtreetech Manta M8P
Host / SBC: BIGTREETECH CB1

Good afternoon everyone! Sometimes it happens that during printing an error appears like

Transition to shutdown state: MCU ‘CB1’ shutdown: Stepper too far in past

Any ideas why this might be happening? I am attaching the log file and gcode :
dino.gcode (5.6 MB)
klippy.log (7.0 MB)

Likely connected to your step_pulse_duration = 0.000005 setting.
This artificially limits the max step rate and with this the max velocity that motor can achieve. If you nevertheless exceed this limit, then this error will be raised.

1 Like

According to the idea, we are already at the limit because of the driver or am I deeply mistaken?

I’m by no means an expert on stepper drivers.

All I can tell you that my (hopefully correct) interpretation of the error is:
You are generating more steps than the stepper driver can process / consume due to its timing constraints. As a consequence, the motor starts lagging behind its target and at some point Klipper is telling you that the “Stepper is too far in the past”

Thank you! After increasing step_pulse_duration and decreasing microsteps this problem no longer appeared.