Z probe won't home, but works

Basic Information:

Printer Model: -CR10V2
MCU / Printerboard:- BTT SKR v1.3
Host / SBC- Raspi V3
klippy.log

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

New CR Touch, Appears to be wired correctly
when I do the testing with BLTOUCH_Debug as outlined in the klipper bltouch doc, everything works great. Touch mode, triggered when its pressed, open when not, pin down, etc
However;
When doing a G28 to home it homes x,y goes to safe home position in middle of bed and times out with an error: No trigger on z after full movement

I’ll paste the snippets from my config, but am at a loss.
I notice that on the z home it puts the position at 500+(539.300), so suspect something is causing the out of bounds error to come up I.e. No trigger on z after full movement
I have tried messing with the boundaries to get it in bounds, but if you increase z max, it sets it even higher. If you decrease z min
have played with inverting sensor pin, inverting, negating endstop pin, pin up touch mode reports T/F, probe with touch mode T/F
Changed all one at a time and no effect, except differing errors

Would be grateful for any and all help, thanks.

[stepper_z]
step_pin: P0.22
dir_pin: P2.11
enable_pin: !P0.21
rotation_distance: 8
microsteps: 16
#endstop_pin: !P1.25 # P1.25 for Z-min # P1.24 for Z-max
#step_distance: .0025
#was getting an error for the endstop pin, but trying virtual probe seems to work now
#still not homing
endstop_pin: probe:z_virtual_endstop
#probe:z_virtual_endstop
position_min: -5
#position_endstop: 0
position_max: 360

[tmc2209 stepper_z]
uart_pin: P1.10
run_current: 0.650
hold_current: 0.450
stealthchop_threshold: 30

[bltouch]
control_pin: P2.0
sensor_pin: P1.24
pin_up_touch_mode_reports_triggered: False
probe_with_touch_mode: True
#stow_on_each_sample = False #slightly faster probing
#x_offset: -52
#y_offset: -16
z_offset: 1.4
pin_move_time: 1
speed: 20
samples: 3
sample_retract_dist: 8.0

pin_up_touch_mode_reports_triggered: True

probe_with_touch_mode: True

lift_speed: 40
samples_tolerance_retries: 3

[bed_mesh]
speed: 250
horizontal_move_z: 8
mesh_min: 20,20
mesh_max: 300,300
probe_count: 5,5
#algorithm: bicubic
fade_start: 1.0
mesh_pps: 2,2

[safe_z_home]
home_xy_position: 155,155
speed: 80.0
z_hop: 10.0
z_hop_speed: 10.0
klippy.log (3.0 MB)

Hello @Latrocinium !

Please take care to upload only the newest logs/configs.
Different ones can lead to confusion.

So the the Z-axes does not move at all?
Does it move to the wrong direction.
Does it crash into the bed?


Please make use of the Preformatted Text feature of the forum editor when you upload code snippets.
Format

Thanks so much for hopping in.
It did not home on z at all, Long/Short, switched z motor cable and was fine.
Did not figure it out until I tried to go back to the old limit switch just to get printing again.
Must have knicked it or something.
Posting my fix in case someone else gets stuck.
Thanks again!

1 Like