"No trigger on z after full movement" with position_min: -100

Basic Information:

Printer Model: Biqu B1 SE Plus
MCU / Printerboard: BTT SKR 1.4
[klippy.log|attachment](upload://nWe8HOr9J8aiYAgdKaeiOwiY8bS.log) (1.2 MB)
printer.cfg (10.7 KB)’

Describe your issue:

As stated in the topic title, if I try to home from anywhere other than the nozzle being driven into the bed, I receive a “No trigger on z after full movement” error. I have tried setting my position_min to as low as -340 so that even if the printer believes it is at 0 when at max height it should home but it does not solve my issue. Any ideas?

Hello @EarthlyTurtwig !

Please try again uploading the klippy.log

1 Like

Sorry about that

klippy.log (2.0 MB)

step_pin = PA15
dir_pin = PA8
enable_pin = !PD1
microsteps = 16
rotation_distance = 8.0213333333333
endstop_pin = probe:z_virtual_endstop
homing_speed = 10
second_homing_speed = 5
position_min = -100    # <--------------- Are you sure about this value?
position_max = 3400

You are running Klipper 0.12.0

Loaded MCU 'mcu' 118 commands (v0.12.0-114-ga77d0790

There is no need for KAMP
Adaptive Mesh is included.


Check your endstops and z-movement direction according to Configuration checks - Klipper documentation

Hi again,

I tried setting my postion_min to a more reasonable number (-5), and that did not solve the issue.
In regards to making sure endstops and z-movement direction, I know these all function properly as I have completed multiple prints on this printer.
Looking at the reported positions when homing, it seems as if for some reason it reports at 571mm until the printhead is at the safe Z home position, then changes to 10mm before z-homing, unlike on my Ender 3 Pro, which reports 374mm the entire time until the probe is triggered.
Ender 3 Pro reported postion:
Screenshot 2024-04-01 080509

Sorry for the split post, I can only do one embed per post.
B1 SE Plus reported postion:
Screenshot 2024-04-01 091525

Not sure whether I understand what you are reporting.

To be on the same page:
The No trigger on z after full movement indicates that Klipper started the homing process and should be moving towards the endstop. If no endstop signal is found within position_max millimeters, then this error is thrown.

Within the homing process, the printer does not report any useable position information, as a position can only be deducted when homing is completely and successfully done. The position is then relative to the “found” endstops.

I’m currently printing, but I will send a video of the issue when the print is done. If my printhead is not touching the build plate when I send G28, Z homing will fail with the message noted above.
Screenshot 2024-04-01 095617
With the reported positions, I had noticed a discrepancy between the 2 printers I own and thought it might be relevant information.

Here’s that video. You can see if I home but the toolhead is too far away from the bed, it will give the error mentioned above, but if I move the nozzle to be touching the bed it will home properly.

Video does not work here…

Changed to a youtube link, hopefully that works

Oh, wow. Have you ever looked at other videos how the z-axis of this or similar printers (e.g. Ender 3) is supposed to be moving?

Your z-axis is “eating away” all steps without actually moving. So after Klipper has sent all required steps to move a maximum of 340mm, your axis actually moved like 5mm → No endstop signal found → Error


  • Electrical issues with wiring, driver or stepper motor
  • Mechanical issues, i.e. the axis binding so hard that it is barely able to move

But I have calibrated my Z rotation distance, I know that it is accurate. That is why I am so confused; I have completed prints on this printer with Klipper.

Just to clarify, in the video when the Z axis moves to meet the bed after the first failed home, that was manual.

The beginning of the video is a homing move, right?

Without wanting to sound harsh: Whatever and however you did calibrate something (see here): As long as the axis is not moving in one fluid motion, without speed change, stuttering, bumping etc, then you just do not need to continue.

You can simply issue a manual move, e.g

G1 Z50 F600 # Move 50mm upwards at your homing of 10mm/s

If the movement pattern repeats, then you either have a severe electrical or mechanical issue.

1 Like

I’m not sure I see what the movement pattern you are mentioning is.

Once I have the printer homed, I can tell the Z axis to move up and down many times without issue. I can upload a video if you want to be sure.

I do believe that the reported position, even if you say that the firmware does not act on that value when homing, is relevant to this issue. I have 2 printers right next to this one that report values larger than the position_max in printer.cfg when homing. However, this printer momentarily reports 510, then changes to reporting 10 and only moves down 1cm.

It is the kind of stuttering during the Z-homing.
It should be a smooth and even motion all the way.
And the stumbling over that corner item is not healthy too. The nozzle is even scratching over the bed. So the homing failed.


With a behaviour like that I would not give a cent for the precision and accuracy of the Z-axes.

Can you give me a timestamp of the stuttering?
Also, the nozzle dragged the bed because I had commented out the Z hop in the safe Z home section to see if that made a difference in behavior and forgot to uncomment it out. Homing did not fail when it dragged the bed, as I have stated multiple times. It fails when the toolhead is further than 1cm away from the bed.

It is from 0:17 up to 0:24. This is so obvious to see.

Honestly, are you searching justifications why your setup is correct or are you interested in fixing it?
Look at videos how a z-axis is supposed to be moving and compare with yours.

In the end, it is your printer and you can do whatever you want with it, but if you come here for support, then it might make sense to follow the given guidance.

As far as any remote diagnosis allows: Either due to electrical or mechanical issues your axis is loosing so many steps that it is only able to move roughly 1cm although Klipper commanded it to move up to 34cm.

1 Like