"No trigger on z after full movement" with position_min: -100

From 0:17 to 0:24 was a manual move. I turned the lead screw. I said this before. There is not an issue with the way my Z axis moves when the stepper is turning the lead screw.

I appreciate that you are both taking time to try and help, but I feel like neither of you are understanding my issue.

If my tool head is more than 10mm from the build plate, it fails to home. Klipper is only telling it to move 10mm down for some reason.

If I move my tool head so that it is less than 10mm from the build plate, going succeeds. I can then tell my Z axis to move up or down as much as I like and the dimensional accuracy is close enough that it should not be an issue for this and it is smooth. No jumping. No skipping.

As I stated before, I have another printer. I have watched plenty of videos of prints in progress. I know how a Z axis should move.

Most probably your probe is constantly misfiring.

In your video a blue led is blinking in your extruder head - it’s your probe triggering.

During Homing sequence - it’s immediately stopped because probe should be silent until it will sense the bed, then it should retry few times (in expected range) - if something goes wrong - you will get that error, or some other error.

It can be a probe itself, it can be a broken probe wire, it can be additional weight on your toolhead, it can be jerky Z movements, etc …

Confirmation of my words are present in your log, when you was playing with settings - few times there was following error registered.

Probe triggered prior to movement


I set my safe Z homing speed to 5 and it seems to be working properly now. Seems as if you were right, probe triggering was causing the issue. Thank you, I’ll have to double check wiring and see if anything is off.
I was looking into a method to filter out bad input data with my probe as it is incredibly sensitive, but the only way I could find was changing my probe section in my config to smart_effector to limit acceleration and implement a pause before probing, but that doesn’t allow me to use probe:virtual_endstop for my Z axis.

If i remember correctly - smart_effector automatically creating probe definition, so most probably your probe:z_virtual_endstop will be valid with smart_effector

1 Like

And it turns out I had just misread the error- it definitely does work, just needed to set position_endstop for stepper_z.
Thanks again!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.