After Flashing - No MCU Found?

Basic Information:

Printer Model: Ender 3 Pro
MCU / Printerboard: Creality 4.2.2

klippy.log (56.4 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

I’m not sure if the klipper.bin file is flashing, is there a certain order it needs to be done. Here is the steps I’m taking;

1: I unplug the raspberry pi from the printer and unplug printer
2: Insert sd card with the loaded firmare.bin file (I renamed from klipper.bin)
3: Plugin and power up printer and wait a few minutes for it to flash
4: Plugin raspberry pi
5: Use putty to login to my raspberry pi
6: Use command to go into Kiauh and go into the advanced
7: Get MCU ID
8: Connect by USB

When I do this it say no MCU found… what would I be doing wrong?

This is a picture of the creality board


Meant to add what I selected when building the firmware


Please read the top of the sample config file and pay particular attention to the section about the clone MCU shipped in recent printers. Your photo clearly shows a GigaDevice chip.

1 Like

Thanks jakep_82, I modified the settings to what I thought would match, but I’m still getting the same “No MCU Found”. I’ve added klippy.log above.

klippy.log (56.4 KB)

What is the output of ls /dev/serial/by-id/* in a Linux terminal?

It says “No such file directory”…

You may have a look here Klipper don't connect the printer - #12 by hcet14
Read the first 11 lines in @UHaas’ printer.cfg.

# Select "Disable SWD at startup (for GigaDevice stmf32f103 clones)"

Good luck, hcet14

I’m not sure what I’m doing wrong… I changed my klipper.bin file to “GTM32Source.bin” and selected “Disable SWD at startup (for GigaDevice stmf32f103)” but I’m still not able to connect to MCU. Where I’ve tried so many different things, do I need to try a clean command or something? I tried the “make distclean && make menuconfig” that I seen in the post but it gives me an error “make: *** No rule to make target ‘distclean’. Stop.”

Attached is the Klippy.log
klippy(24).log (208.3 KB)

Just wanted to thank everyone for your help. I figured out my issue… after all that work, figured out it was the cable. Lol, I’ve worked for two days trying to get it going.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.