Can't get rid of layer lines

Basic Information:

Printer Model: Creality Ender 3 S1 Pro
MCU / Printerboard: RaspberryPi 3B+ and stock S32F401 variant.
klippy.log (24.9 KB)

Describe your issue:

My printer is about two month old at this point, and I switched to klipper a week back to experiment with input shaping, pressure advance, etc. I have been generally extremely happy with the results, until one fateful day when my filament ran out and I replaced filament mid print. There was an immediate degradation of print quality

And try what I may, I haven’t been able to get rid of this issue. Things I have tried.
Disabling input shaping
Disabling pressure advance
Ensuring bed is level
Making sure all belts, screws are adequately tight
Reducing speed and acceleration to 60mm/s and 500mm/s^2.

Here are some results
ibb[dot]com - R3JH2JS

These layer lines/z banding/ whatever this issue is, is typically most visible on one axis along the y-carriage.

I don’t think it is the filament though, since I haven’t had this issue with this filament before. And similar issues are observed with different filament.

ibb[dot]com - dBR2c2g

(Both the black and white filaments are the same brand and make, I am awaiting shipment of a different filament to run tests with, but I have had successful prints with this filament before - ibb[dot]com - B2PGXkK)

I am at a loss as to where to look for potential solutions. Any help would be greatly appreciated.

This very much looks like a mechanical problem in the extruder or a clogged nozzle.

I took apart the whole extruder assembly and cleaned everything. Additionally changed the nozzle and did several cold pulls. Didn’t help.

I have also noticed that all the banding occurs at the same Z height. Maybe this is a clue as to what is happening?
(Nothing obvious is wrong with the z axis leadscrews and I cleaned them)

Well, I do not know your printer. However, I have never seen a software / firmware or slicer problem to be causing this type of printing defects. Unless you cranked up velocity and acceleration to some unhealthy amounts → Note that the limits in the printer.cfg are not absolute, they can be overridden by the slicer.

Typically, such effects point to a hardware issue in the motion or extrusion system.


My 2 cents agree with Sineos. If you look carefully at the first image you uploaded, where you changed the filament mid-print, At the point of the change you see a black deposit embedded. Correct me if I am wrong, but if this is indeed embedded in your filament it is most likely carbonised filament. Your nozzle heat-break system will most likely be a 2 part system, I.E. 2 different parts. In between the cracks between these parts there are always minuscule crevices where plastic remains for a lot longer then is ideal. The mid print change probably dislodged some if this and started to partially block the pathway of your filament.

If it was me I would take the whole assembly apart and check each path from above the heat-sink down to the tip of the nozzle and rebuild it step by step taking care there are no internal diameter differences or misalignment.

With the many cloned parts out there I noticed that even parts which are supposed to be able to fit together, I.E. V6 compatible, they do have differences. These differences could eventually lead to a stacked tolerance error that is larger then ideal. It will print for a while but then suddenly all hell breaks loose and you have this.
I am speaking from experience with my V6 compatible parts. Almost a year without any trouble and suddenly I had layer adhesion trouble, under extrusion and various other problems all similar to what you show here.

My solution was drastic though. After months of trying I decided to replace the hotend for the Revo Micro from E3d. Here the nozzle and heat-break are one part and I never looked back.

But you don’t need to go this far of course. A good clean and analysis of the parts you have used should put this right. Just make sure you always use good quality branded parts to build up your hotend. Nameless parts from dubious origins are always full of surprises. Even when you have good quality parts, if they come from different manufacturers they can cause tolerance issues. I would recommend to find a manufacturer that works for you and stick with them, don’t mix different makes.

Good luck and let us know what you find.

Yeah it does seem to be a mechanical issue. However several trials and tribulations have been unfruitful. For example I have taken apart and assembled the hotend and made sure the whole path is clean without success.

My problem is that I can’t seem to pinpoint whether it is an issue with play in some axis or the extruder hotend assembly. Is there a way to rule out one of these? Especially since all the artifacts happen at the same Z-height. Even with changing layer heights and filaments.

There is more experimentation and pictures at the klipper subreddit.

I would NOT recommend a benchy for testing this. The benchy design is anyway very prone to layer lines on the hull and very much depends on used slicer / slicer settings and printer how dominant they are.

I looked at your other posts on subreddit and see the same black deposits.
Can you please tell us if these are hard deposits inside the plastic and you cannot remove them, I.E. embedded?
If they are this is your problem.
And you keep saying it starts at the same height but I respectfully disagree. On your photos I see several that have it sooner as well as later, basically random with perhaps a majority that starts roughly there where you think it starts.

I stick with my previous conclusion that you need to get the whole hotend apart and check for path clearance. This is not just looking through it and determine if you see light, it is proper checking that there are no nooks and crannies which contain carbonised plastic.

Once the parts are totally clean, check they match properly and they line up correctly without too much of a internal diameter difference or step.
This is the biggest issue with regards to carbonised plastic. Traps where the flow is reduced to zero and plastic remains there for months.

With regards to play you should be able to detect it by simply trying to move your carriage from left to right or back and forth. It is possible that during the filament change you pushed or pulled a little too hard and something is loose.
On my creality I had once the threaded nut come loose from the carriage backplate and the whole thing had about 0.5 mm play. Check that too.
If that is a firm no, then back to the clogged pathway for me.

The most suspicious thing to me is that this started happening when you did a filament change and now continues even after switching to a different filament. That suggests to me that there was an unintended physical change to the printer during the filament change, perhaps as a result of some physical force that was applied in an effort to change the filament quickly.

Couple things I would check if it were my classic Ender 3:

  • Make sure the X gantry is level and doesn’t wobble on the roller side. (May not apply if your printer has dual Z.)
  • Make sure the Z axis isn’t binding anywhere. You’d normally do this by rotating the lead screw by hand and feeling for any places that seem “sticky” or requiring a little extra torque. I don’t have a dual Z printer but I think that binding can occur if one of the Z homing switches gets out of place. If the two Z=0 positions aren’t on a plane that is perfectly perpendicular to the lead screws, there can end up being unwanted forces that prevent the Z movement from being consistent.
  • Make sure the hotend is firmly attached to the X carriage. The stock hotend on the original Ender 3 only had 2 bolts holding it to the carriage and if one of them got loose, the hotend would pivot up and down. The movement could be imperceptible but it would produce prints that look like yours. This problem could actually be amplified by multiple attempts to partially disassemble things for cleaning. (Keep in mind that the actual hotend could be loose even if the fan shroud is bolted down tight.)
  • Similarly, make sure the X carriage is moving side to side freely but without any wobble with respect to the X gantry. Having the hotend firmly attached to the X carriage is good but you’ll still have problems if the whole X carriage is wobbly.
1 Like

So the black deposits are most likely from the black PETG that I printed with, the nozzle was a little loose and it leaked all over the hot-end exterior. I have cleaned it the best I could, and I have had several successful prints after this mishap. There are still some stuck to the outside of the hotend. Is there anything else I can do in this regard? I’ll definitely do a more thorough inspection but with my limited experience I wouldn’t be surprised if I missed something staring me right in the face.

It is not all at the same places but there are significant features at the same place, or so I think. Could still be a hotend thing, so I would definitely like to rule it out. Is there a test print to check for inconsistent extrusions? I was thinking a series of close parallel lines, something where this would show but the Z-axis artifacts wouldn’t?

Thank you for your suggestions.

  • It does have dual Z, and I don’t know of a way to make sure they are “level”.
  • There are no z axis limit switches, I think the printer just relies on the CR-touch to home.
  • There are 4 bolts, and I did take it all apart and put it back with very little in the way of changes.
  • The X carriage seems good. Moves well without much in the way of wobble.

But, I have a hunch that you might be on to something. One of the rollers for the Z-axis (X gantry) was loose, which might have caused the two sides of the gantry slightly differently leading to this. However, I am yet to figure out a way to set them to the same level. It doesn’t reach as low as the motors (bed gets in the way) or as high as the limiting points (cable length), so I can’t think of a way to get them level. Maybe I can print a block and use that to make sure the offset from the motor to the gantry on both the leadscrews are the same? Is this a reasonable approach?

As far as the leadscrews go, just did a check with my hands - on the way up it is kinda hard to rotate so very difficult to say if there are inconsistencies. On the way down it feels reasonably smooth, but it feels like it rotates in “clicks” but that just maybe because of the stepper motor magnets maybe? I don’t trust my own judgement here, since I don’t have a normal baseline.

See if this helps:

Or this: Reddit - Dive into anything

If the Ender 3 S1 Pro doesn’t independently home the Z steppers, then it simply assumes they are level so you have to make sure they actually are. Also, pay special attention to the parts of the video that deal with setting the eccentric nut(s). Generally you want those to be set so that the rollers are tight enough to eliminate any wobble or slop, but not so tight that they impede the movement of the gantry and put excessive force on the rollers.

1 Like

If the gantry is tight, but not level, I.E. parallel with the bed, it would not cause this problem but rather a un-level first layer and non square prints. This could result in prints coming loose or simply showing de-lamination of layers.

The first layer is easy to check. If the lines are properly closed en level thickness in one place, but elsewhere along the X direction they are open, not touching or flattened, squished and rubbed out, you know the gantry is not parallel with the bed. You can set the bed or , better if the gantry is not perpendicular with the z axis, is to tram the gantry first so it is perpendicular with the z-axis. After that you do a bed level again, but I do not think that is the cause of this particular problem.

Check all the other options first like loose parts, wobbly hotend and so forth.

Your description of the feel of those steppers is correct. They click as if they are held in certain places by magnets, which is exactly the case. Also up would be harder but you should still feel if they are roughly the same left and right.

Final note, when my hotend came loose all I noticed was very disorderly layer lines. This sudden change in extrusion does not happen from a loose part unless it is a loose part in the extruder itself. When you changed filament mid print, did anything happen that you now think was strange? Check if the pressure arm is still moving ok and not binding. Check the dual extruder gears are engaging correctly and that both gears are still freely rotation and not wobbly. Also check that they are clean and free from built up plastic in the teeth.

Lastly yes if you have plastic deposits on the outside of the nozzle it could also fall off and show as an embedded foreign particle. Not good but not the cause of this problem.

1 Like

Sorry for the late reply, I was travelling for a while.

Firstly I have tightened slop on every axis there is. And I checked the dual z level with the method described in the service video as shared by @theophile .

I also took apart the extruder and I did find that one of the two extrusion gears were misaligned, one had moved slightly along the rotation axis and the teeth were binding partially. However, fixing this didn’t fix the issue.

I have pretty much eliminated extrusion as the culprit here.

This is a “cube” printed in vase mode. Note how two of the faces in the same print are smooth as can be, can’t even feel anything with my fingers, but the other two are horrendous (highlighted in red). Also attached picture of the first layer in case that helps.

I am even more puzzled and out of ideas. Why would two faces be problematic and two others be fine? Does not even rule out an axis.

Also I occasionally here scraping noises during travel moves, maybe the extruder is squishing down the layer below causing these issues? Could this be the answer? If so, how do I fix it. Does this even make sense given that 2 sides look fine and 2 don’t?

It’s conceivable that something like this could happen if the bed plane isn’t parallel to the toolhead plane, but that sort of thing would normally be dealt with by the bed mesh.

Have you tried a new nozzle? I’ve had issues in the past with poor surface quality on only one “side” of a print when the nozzle orifice has worn unevenly. This could be exacerbated if, in your attempts to clean your extrusion path, you used a needle file or some other metal object to try to clean the nozzle.

1 Like

Fully agree with @theophile. In addition, you might want to take a look at Axis Twist Compensation - Klipper documentation


Have you tried a new nozzle?

My nozzle is brand new, it was changed during the troubleshooting in this very thread. It has only been used for say 50 or so prints mostly trying to fix this issue.

@Sineos - Axis twist compensation didn’t help. Additionally, my parts don’t stick to the bed anymore :frowning: First layers have started to warp off the bed after a few layers. Maybe I did it wrong, or it wasn’t the issue.

One other strange thing - I printed a single layer wall just to see if it was the X or Y travel causing the issue.

Turns out when printing one axis at a time, the layers are flawless, barring artifacts on the corner. However, when I print something with moves in both X and Y those artifacts show up again. This is extremely strange and I can’t come up with an explanation.

Here is another picture illustrating the issue.

Is there a slicer/firmware setting that can fix this, or is this hardware?

@Sineos @3dcase @theophile Thank you for all your help. I think the issue is resolved. Since, I pretty much took apart everything and put it back together and several issues were fixed like flat rollers, loose screws, tramming, etc I can’t definitively say what was wrong, but the most likely culprit was extrusion slipping. Tightening the extrusion tension screw had the most pronounced effect on fixing this issue. Everything looks good now.

Thank you all again for taking the time to respond to my query. I learnt a lot.