Ender3 V2 & Ender 3 V2 Neo Firmware Flashing Issues

Howdy
So I’ve had a doozy of a day

Awhile ago I installed Klipper manually onto a RP4(Raspberry Pi 4) with My E3V2Neo and it worked great, then I entirely wiped my RP4 to install KIAUH and it worked great.

I now bought an Ender 3 V2 and wanted to add it to my Klipper setup, so I used KIAUH to uninstall klipper and moonraker from the RP4 and reinstall them but selecting 2 instances for each and this worked great

Here’s where the trouble starts, I go through making the firmware file for the new printer and put it onto an SD card and flash the printer, I use KIAUH “Get MCU ID” and I only get one(The Neo Printer), I disconnect the Neo and try again and get no MCU detected.

I go through flashing the printer tens of more times trying everything, following the config properly, renaming every .bin file different, accounting for GD MCU instead of ST, trying with screen plugged in and not plugged in, every time with the new firmware the screen stays on “Creality” instead of blank like it should be.

I tried reflashing the regular firmware from creality and it did so fine, working like a normal printer, but klipper firmware just doesn’t.

I then tried reinstalling the klipper, moonraker, and mainsail instances. Same issues.

At one point I tried reflashing my Neo and it didn’t work and now the Neo wont flash ANY firmware, even creality firmware. The screen on this one also just stays on “creality”

I’m thinking of just buying two new motherboards for the printers, maybe ones better for klipper or whatnot.

Looking for solutions or new motherboards.
Thanks

Update:
-Could it be my RP4 is making bad .bin files?
-Neo now flashes Creality Firmware

1 Like

I cant really help you with the klipper errors - I dont remember how I flashed, just that it took a lot of grit and frustration (Creality 4.2.2 board w/ GD chipset).

I have heard that the SKR Mini e3 is the best board for the ender 3, it is a drop-in replacement. The disply pins must be reordered to work, but that wont matter since klipper doesnt support the display.

Did you happen to solve this? Seems there’s a few of us posting around here with the same issues, on the same hardware.

I haven’t solved it yet, I mentioned my issue to another 3d printing nerd and he said that with creality printers, since they are pretty cheap, so is the main board, so it’s just an issue that only a new Mai board can solve. There might be another way, but honestly I’m ok with a new main board since a new, even better one is only $30.

I did solve it, but i dont remember how. It involved setting the firmware-wizard chipset to GD and using a microsd card to allow the firmware to load.