Move out of range: 37.259 -49.197 1.000 [0.000]

Basic Information:

Printer Model: Ender 3 V2
MCU / Printerboard:4.2.2
klippy.log [klippy (4).log|attachment](upload://8F3T2jKc1A432rpNoF0k6Gk7T2y.log) (526.0 KB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

my problem this Messege (Unknown command:“M302” )&(Move out of range: 37.259 -49.197 1.000 )

Describe your issue:

…I have modified my printer to print clay … so i need to use cold extrusion
So i used in my start machine setting in the slicer the following:
; Ender 3 Custom Start G-code

M302 P1 …N.B" i tried also P0"

G92 E0 ; Reset Extruder

G28 ; Home all axes

G92 E0 ; Reset Extruder

G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish

… and in the end setting
M302 P0

G91 ;Relative positioning

G1 E-2 F2700 ;Retract and raise Z

G1 E-2 Z0.2 F2400 ;Retract and raise Z

G1 X5 Y5 F3000 ;Wipe out

G1 Z10 ;Rate Z more

G90 ;Absolute positioning

G1 X0 Y{machine_depth} ;present print

M106 S0 ;Turn-off fan

M104 S0 ;Turn-off hotend

M140 S0 ;Turn-off bed

I got the unknown command M302!! … i need to cancel all Temp … the bed and extrude temp permantly
any help

M302 is not a known GCODE for Klipper.

You basically have two options:

  1. Set respective limits:
  2. Wire a thermistor and simply let it measure room temperature and set appropriate limits.

For the other error see Move out of range: X Y Z [E]
Most likely due to a mixup between G90 / G91. I’d recommend to work with G90 and always give coordinates as absolute in relation to your 0/0 origin.
G91 is incremental / relative, this means always moves from your current position and as such easily creates such errors. In your case most likely the Y axis with a commanded target of -49

Hello Bro how are
As i mentioned earlier … that … know i’ve modified my Ender 3V2 to print Clay … so i don’t need heaters or hotend or sensors or even fan !!
So i have removed its cables
:slight_smile: So it gave my the following error
"Klipper reports: SHUTDOWN

MCU ‘mcu’ shutdown: ADC out of range
This generally occurs when a heater temperature exceeds
its configured min_temp or max_temp.
Once the underlying issue is corrected, use the
“FIRMWARE_RESTART” command to reset the firmware, reload the
config, and restart the host software.
Printer is shutdown"
Can u help my in this modification

cool :ok_hand:

Your klippy.log might help.

Good luck, hcet14

klippy (6).log (158.3 KB)
Sorry … here the log attached …

1 Like

Connect all connectors back!

Then you have to tell Klipper the margins you expect. You are printing clay => no need for a hot bed, etc… There is only one way. Read the very good documentation and set the right margins for your clay print.

1 Like

i have Removed all following cabels ( thermo. sensor, Hotend, the 2 fans )
Also in the sliced file i have to modify with same reading in MainSail in my case was -43
( What i modifed in the file was the following lines
*;nozzle_temperature(°C): -43
M104 S-43
M109 S-43)
… I believe this will solve the first issue

Regarding the Move out of range: X Y Z [E]
i didn’t get your point … ill attach file i want to print in GCODE and klippy.log
2mmCE3E3V2_viktoria_with_turner_logo.gcode (1.4 MB)
klippy (6).log (158.3 KB)

Thnx for you kind help and time Bro … But i believe i have solved the Temp Issue as i mentioned above … thanks again … realy appreciate your support

1 Like

Your gcode file looks strange:

G0 F6000 X37.259 Y-49.197 Z1
G1 F1200 X38.172 Y-49.185 E0.28626

It tries to move to a Y position of -49. Your printer is defined as printing area between 0 and +235. Seems your slicer is messed up.

1 Like

Obviously set the origin to the middle of the bed.


Both you and Sineos are right … except that it was marked the origin in the middel of the bed … so i removed its selection … and the slicer works fine NOW!!!
Thnx Buddies

1 Like