Multi motor Delta C stepper issue

Basic Information:

Printer Model: 48v custom AWD Delta
MCU / Printerboard: SKR pico for the main board, 2 supernova boards for 5160 steppers .
[o] klippy.log

Describe your issue:

Good day,

I built a 48v AWD Delta. I’m running an SKR pico for my main board ( heaters, therms, and fans) and 2 Supernova boards from Annex engineering at 48v for all steppers with Bigtree 5160 pros( annex products are fantastic).
I’m having issues with Klipper and running 2 C steppers. I have no problem with my config running Stepper A, A1 and Stepper B, B1 but when I add Stepper C, C1 only the C Stepper moves not the C1 with it. The config for the steppers and driver are the same except for the name change ( a,a1,b,b1,c,c1, extruder).
Testing this, I’ve tried different steppers and stepper drivers ( fysec to Bigtree). I’ve tried running an octopus Pro with the same results ( even after changing stepper ports and drivers ). Force moves and Buzzz commands do work but with no power behind them( stepper can feel like a command is working but very lightly not enough to move but enough to feel the stepper flutter). my last attempt was to verify it’s not a hardware issue but moving steeper names around in my config. A&A1 to B&B1 - B&B1 to C &C1 - C&C1 to A&A1. Each time I had the same issue with C1 not moving correctly no matter the Tower I used.

I don’t think this is a hardware issue. Does Klipper allow 2 C Steppers?

Hello @Macgyver1307 !
The klippy.log would be a great help

I’m currently running my steppers in series till I can identify the issue … I will reconnect this to 1 stepper driver per motor shortly and pull a klippy file . My concern is less in the set up but more in if klipper is set up to run multiple c motors on a delta ? Or if the multi motor .py is a different file and it doesn’t have multiple c motors listed … I apologize but I’m not that Versatile in python but learning .