Printing on the Same Line Height/Z-Axis Issues

Basic Information:

Printer Model: PrintrBot 1403
MCU / Printerboard: AR100/Recore
klippy.log :
klippy.log (911.8 KB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue: The print is only printing the base layers well.

I keep printing w/ different calibration steps, PROBE_CALIBRATE and HEATER_CALIBRATE, yet my builds are starting to stop lifting and rising when printing.

I put in the Z-offset but this has not cured the issue so far.

See the photo for actual representation of ideas in the rising of the Z_axis. Oh and I tried different rotation_distance ideas b/c of me “updating” the lead screw.

I can home now w/out issue. I can move the XYZ axes and I have not figured out what exact issues could cause the print to keep printing on the same Z_Axis level.


Most likely one of two potential reason:

1 Like

@Sineos ,

Okay…I will look over the link you have left.


Hello @Sineos or Anyone Else w/ Sound Advice Here,

@Sineos …I read over the link you posted. It is similar to the config portions in the docs. to Klipper if not exact. Anyway, nothing has helped so far.

8mm diameter, w/ 1 start, and 2mm pitch. I put in the value and while trying other values for this cube print to start off, I noticed that I could also change the microsteps once the rotation_distance has been configured.

Anyway, I know it needs to be exact but I did try other values outside of the exact value.

I tried 2 to 16 in increments of 2. Nothing is making the Z-Axis rise…

I altered the height of the gantry for the Z-Axis too. I lowered it. I finally got it to where it would print flat enough on the build surface.

I set up the PROBE, PROBE_CALIBRATE, and performed the offset values also for XYZ.

I had this issue before w/ this specific PrintrBot 1403 w/ a 7mm and/or 1/4" lead screw.

This fellow showed me to use PID values to handle such a lead screw. I cannot reconfigure his steps, i.e. computer crash since then and lost materials (notes and paperwork).

Is there any other ideas you and anyone else has currently to handle lead screws on the 1403?


P.S. I will keep trying, i.e. as I just put a larger bed on this printer to finish off some prints that I wanted to make. Anyway, thank you so far for the advice and knowledge. I had 1.58 for the lead screw of 7mm and/or 1/4" beforehand.

This lead screw is 8mm or roughly 5/16" in diameter w/ an arbitrary value for the start and pitch.

I type arbitrary there b/c my current tools are not equipped to handle the measurements of start and pitch. I have a couple tools to use but all have failed, i.e. calipers and fine tooth mm ruler.

Anyway, thank you for any advice you can give.

Don’t mix up metric and imperial lead screws.
Although they have almost the same diameter, they have different pitches.
If you are not sure, you can measure the pitch.

You only can set the microsteps to 1,2,4,8 and 16. And for the TMC 2209 further on to 32, 64, 128 and 256).
Keep in mind: The higher the amount of microsteps, the less torque you have. So 16 is usually the way to go.

This makes me wonder. PID in 3D printers is used for the control of heated elements (hotends, beds) and do not makes sense with lead screws.

[tmc2209 stepper_z]
uart_pin = ar100:PB1
tx_pin = ar100:PB0
uart_address = 2
run_current = 0.750
hold_current = 0.500             #<---
stealthchop_threshold = 250      #<---

You may increase the hold_current of stepper_z.
You also may set stealthchop_threshold to 999999

1 Like

Okay. I will test these ideas. Thank you for not giving up on me here.


P.S. You are most likely right about the PID/Lead Screw options. I may have taken some poor notes years ago. Forgive me…

Also and okay about the metric vs. standard approach. I finally found the “paperwork” on this lead screw. It is an 8 mm diameter leadscrew. It was an older purchase from '18 and the company no longer sells it. Anyway, thank you for your ideas. Off to test!

Slight correction - you don’t have less torque over a step, you have less of a difference in torque between microsteps which results in poorer positioning of each microstep. There will be cases where there is no turning of the motor to an unexpectedly big jump as the torque builds up over several microsteps and reaches a point where the friction of the system is overcome.

1 Like

Hello @EddyMI3D ,

What does the 999999 value for stealthchop_threshold entail under the Klipper guidelines?

I mean…does it handle tmc2209 devices specific to some value? All I know is that I tried 999999 and the z-axis is no longer operational.


P.S. I will try to get back what exactly has happened but that stealchop_threshold: 999999 command created an instance of up-down movements that are too fast for a leadscrew.

It should turn stealth shopping always on. One never knows what velocity the slicer produces, so it it is quite high.
If it is not working any more, it’s a bit strange.

1 Like

For moving torque: Yes.
But I more had the holding torque in mind:

1 Like

I tried 0, 100, 250, 500, and 999999. None are quite right so far…

My print is very smashed so far. I have altered the klipper config files many times over and I have not come across the correct one just yet.


P.S. I used to use this config for this printer and it worked, how? Who knows? I surely do not.

I just added an upgraded, 8mm diameter leadscrew and a new bed. The only real big difference here is that the x-axis can handle 230mm instead of 152mm. Anyway, thank you all for trying w/ me.

Proper movement of you z-axis should be Independent of using stealth chop or not.

kinematics = cartesian
max_velocity = 250
max_accel = 1500
max_z_velocity = 5
max_z_accel = 50

Important for the leadscrew Z is a sensible max_z_velocity and yours is good (usually between 5 and max 20 / lower is better).

You really need to figure out the proper rotation_distance for your lead-screw. Usually when you buy one it should be accompanied with the respective technical data like, Leads, Starts, Pitch. If not, maybe contact the seller.

Once that setting is secured and you still have issues then most likely you have some mechanical issues like binding etc.

For the z-axis, I’d recommend to stick with spread cycle. This means set stealthchop_threshold: 0

1 Like

Okay @Sineos ,

No issue. I will try 0 instead this time.


P.S. The leadscrew was purchased in '18 and they no longer mfg. it. I will try another one w/ good paperwork one day.

Hello @Sineos ,

Also…and this could be it. I have a flimsy coupler for the attachment from the motor to the T8 leadscrew. I will invest in a rigid coupler.


@Sineos ,

Seth here. I tracked down some oddities, more starts, in the leadscrew in question that has given me issues on calculating starts and the pitch. Anyway, please view the photo. I was using the leadscrew on the left of the photo. I am going to rebuild w/ the leadscrew on the right:


P.S. Thank you guys for putting up w/ me so far.

Just from such pictures, I cannot tell what kind of screw this is

Thread rotation_distance
M8 2
M8 1.25
5/16 1.41111

Table above are the most common lead-screws. I suggest following procedure:

  1. Measure the distance between your X gantry and the top of your bed
  2. Command the gantry to move up 20 mm
  3. Measure again and do <second measurement> - <first measurement>
  4. Calculate
    rotation_distance = <current_rot_dis> * <result No. 3> / <20>
  5. Compare to the table above and see if you come close
1 Like


It seems that for rotation_distance, 2 or 4 work well but both are not working on the leadscrew w/ more starts.

When I say, “not working,” I am describing the print once the homing and all subsequent calibrations have taken place.

The flexible coupler is no more and I am using the M8 leadscrew w/ the many starts now.

When the print starts…

  1. The machine homes
  2. The homing is mm away from the bed
  3. Then…the print starts
  4. Then, it digs into the bed

It is like it is not understanding where and at what distance it homed.

Could this be due to step or the z_offset or is this due to something else entirely?


P.S. Please see the update below:



Done. Sorry to harass you guys…

Oh come on, @silver2row. At the danger of repeating myself: There is no OR. Between these two setting is a factor x2 in movement distance. Before you have not validated your correct rotation_distance it makes no sense to continue with anything else.

1 Like

Yes sir. No issue.

I will attempt this non-error prone ideas I keep up w/ currently. Thank you for reiterating the point.

I have no paperwork on these or this specific one that I am using. Is there a particular way to measure?

I think it is an oddball T8 or 8mm of some kind. I have no way to tell so far.


P.S. Anyway, I will attempt to read up more on measurements and how to measure 8mm/T8 screws. Anyway, check out my Behemoth so far!


W/ the leadscrew on the left, do you think it is ACME or trapezoidal? I know it is not high helix.

I only know the co, when it was sold to me, said leadscrew at 8mm.

Another Update

8mm diameter
5 starts
1.6mm pitch

Send guidance sir…please.

8mm diameter
5 starts
1.6mm pitch


Would equal a rotation_distance: 8

1 Like