Unknown command:"Z_OFFSET_APPLY_ENDSTOP"

Hello to everybody. I get the following error [Unknown command:“Z_OFFSET_APPLY_ENDSTOP” ] when Im trying to update z offset from fluidd interface save button.
I have a delta kossel printer with manual probe system (microswitch)
Any idea?

klippy.log (354.1 KB)

Delta printers don’t have a z endstop, so this command will not work.

Ok, if this doesnt work how can I save a new z offset (in easy way) permanently?
Now, every time I turn on the printer I have to remember to change z offset manually.
And why does it show this button if it doesn’t work on delta printers?

The button is being shown by Fluidd. You would need to ask the those developers why it’s being shown.

You can either add a gcode offset to your start gcode, or you can adjust the endstop positions of your A, B, and C motors.

Try this one: Z_OFFSET_APPLY_PROBE

https://www.klipper3d.org/G-Codes.html#z_offset_apply_probe

Thank you all, I think its a fluidd problem, jakep_82 is right, I rose the topic in fluidd core team.