Z-Tilt adjustment should respect probe offsets

When setting up Z-Tilt on my printer. I attempted to run it for the first time, my nozzle crashed into the bed. This is because my probe is to the right of the nozzle, and I used the x-max value for my probe position, and the probe was off of the bed and didn’t trigger. This also means that in order to probe the left edge of the bed, I’d have to use a negative x-coordinate to position the probe closer to the screw.

I propose that the z-tilt adjustment should take configured probe offsets into account, so that the coordinates are more intuitive to configure.

I’m not sure, I understand what you are reporting.

  • Z_TILT_ADJUST requires probing
  • All probe commands in Klipper are relative to the probe’s coordinates and need to be setup accordingly
  • It is a one time setup
  • For some explanation how this works, refer to Understanding X and Y Axes Limits and Homing

I apologize for the confusion. I can hardly make sense of my original message either.

I had the following setup:
x_offset: 60
y_offset: 0
pin: ~!PB7
speed: 10
samples: 3

z_positions: -90, 180
455, 180
points: 0, 180 # Left edge of bed, center
360, 180 # Right edge of bed, center
speed: 100
retries: 3
retry_tolerance: 0.2

Using this config, performing a z-tilt adjustment caused the nozzle to crash into the bed on the right side because the probe was past the right edge.

Applying the probe x-offset myself (updating the z-tilt “points” to 0, 180 295, 180) successfully performs the adjustment.

My thinking was that the “points” should be interpreted as “where to position the probe” as opposed to “where to position the nozzle”

Does that make more sense?

I think a complete klippy.log would us give much more information.

Basically I agree with your points.
I think it is a bit unfortunate that Klipper is not consistent here:

  • For the bed mesh min and max values you need to specify probe coordinates
  • For the tilt adjust one needs to specify nozzle coordinates (while making sure that the probe stays on the bed)

Both systems have their ups and downs: When starting with Klipper I thought it is strange to have to correct the nozzle coordinates by the probe’s offsets to get it right.

What I’d at least appreciate is to have it consistent but from today’s point of view it would be a “breaking change” (unfortunately literally breaking) for a lot of users, so guess the best option is to RTFM and to leave it like it is.

1 Like

I was going to suggest adding a specific callout to that face in the z-tilt documentation, but there already is one:

Specify coordinates of the nozzle and be sure the probe is above

the bed at the given nozzle coordinates.

Straight from my config… Thanks for the response, fellas. I’ll read twice post once next time. :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.